Search found 16 matches

by skywave
Mon Jun 05, 2017 2:08 am
Forum: ESP8266 SDK
Topic: ESP8285 custom board no Wifi on wakeup
Replies: 5
Views: 458

Re: ESP8285 custom board no Wifi on wakeup

Hi There, Thanks for the reply. I have flashed the AT firmware. Same result. Consumption is around 40mA, all AT commands work, including changing modes (station, AP, SoftAP+station). No Aps found - i cannot detect SoftAP. System returns MAC addresses, chip ID and everything else. Besides radio all o...
by skywave
Sat Jun 03, 2017 2:46 am
Forum: ESP8266 SDK
Topic: ESP8285 custom board no Wifi on wakeup
Replies: 5
Views: 458

Re: ESP8285 custom board no Wifi on wakeup

Is there a way to check if RF is on or not? wifi_set_sleep_type function doesn't seem to influence. Consumption is still 40mA - radio functions return true (OK) but no APs found / no SoftAP detected - seems like the rf is off.
by skywave
Sun May 28, 2017 4:20 am
Forum: ESP8266 SDK
Topic: ESP8285 custom board no Wifi on wakeup
Replies: 5
Views: 458

ESP8285 custom board no Wifi on wakeup

Hi There, I have made a custom board based on ESP8285. I have made a small program that scans for APs nearby (taken from your examples), however no APs are found. The ESP8285 is only drawing 40mA from the power source. Is it possible that the radio is off. No errors appear when calling the scan func...
by skywave
Fri May 26, 2017 1:35 am
Forum: ESP8266 SDK
Topic: ESP8285 bootloader version to use
Replies: 1
Views: 133

ESP8285 bootloader version to use

Hi There, I have built a custom board with the ESP8285 chip. I want to use OTA uptades so I must use one of the bootloaders provided on your last SDK: boot_v1.2.bin / boot_v1.6.bin / boot_v1.7.bin - which one should I use. What's the difference between them - is it somewhere documented or should I u...
by skywave
Wed Feb 22, 2017 6:18 am
Forum: ESP8266 HDK
Topic: ESP8285 ADC (max voltage)
Replies: 1
Views: 491

ESP8285 ADC (max voltage)

Hi There, I would like to connect a temperature sensor to the ADC (TOUT) pin. What's the max voltage ADC can read? Is it 1V? If yes, does applying a 2V voltage to the ADC damages the ESP8285? Between 0ºC and 80ºC the voltage will go from 1V to almost 0V, but below 0ºC the voltage will go up to 1.5V ...
by skywave
Tue Sep 06, 2016 8:46 pm
Forum: ESP8266 SDK
Topic: WPS in AP+STA Mode
Replies: 3
Views: 872

Re: WPS in AP+STA Mode

Hi There, The idea is: If the network connection has not been setup yet - the device will start in AP+STA with a web user interface, so that the end user can connect to the device network (AP) and configure it. However if the end user has a router at home with WPS, it would be very good I we could a...
by skywave
Fri Sep 02, 2016 12:43 am
Forum: ESP8266 SDK
Topic: WPS in AP+STA Mode
Replies: 3
Views: 872

WPS in AP+STA Mode

Hi There, Is it possible to use WPS when ESP8266 is in AP+STA Mode? I would like that the device tries to check for a WPS router (config) while maintaining a web server (user interface) available. That way the user of the final device could use WPS if available (on his router) but could also connect...
by skywave
Tue Jul 26, 2016 7:19 pm
Forum: ESP8266 HDK
Topic: SPI Flash Size 0x1440ef
Replies: 4
Views: 1856

Re: SPI Flash Size 0x1440ef

Hi There, Thank you for your reply. The flash chip has the following written on it: 8C429 0G1014 and the supplier has replied confirming the 1MBytes size, but I still cannot read from positions above 512K. Is there a table where I can check the manufacturer / ID / size of chip? Is there any other so...
by skywave
Tue Jul 26, 2016 2:20 am
Forum: ESP8266 HDK
Topic: SPI Flash Size 0x1440ef
Replies: 4
Views: 1856

SPI Flash Size 0x1440ef

Hi There, I'm developing a project with the ESP-09 module. When I read the Flash ID it returns: 0x1440ef - I presume this means (0xEF) Winbond (4014) 8MBit -> 1Mbytes Flash chip. However when I try to read from positions above 512K for instance: spi_flash_read(524288, (uint32 *)b, 128); the read fai...
by skywave
Mon Nov 16, 2015 3:36 am
Forum: ESP8266 SDK
Topic: RTC Interrupt Handling
Replies: 2
Views: 995

RTC Interrupt Handling

I am generating a 1000Hz PWM signal on GPIO with 0.5us ON. On RTC interrupt I set the pin (ON), wait for 0.5us (nops) and then clear GPIO, clear interrupt and reset RTC timer. However more than once a second the interrupt instead of taking 0.5us takes 2us (at 160MHz) or 3us (at 8MHz). I don't know w...

Go to advanced search