Search found 94 matches

by blubb
Sat Jan 13, 2018 8:51 am
Forum: ESP8266 HDK
Topic: FCC problem - Spectrum analyzer shows unwanted transmission when startup
Replies: 11
Views: 329

Re: FCC problem - Spectrum analyzer shows unwanted transmission when startup

Maybe one more idea:
Did you flash the latest esp_init_data_default.bin?
Recently they changed something, so there is a new version "8":
https://github.com/espressif/ESP8266_NO ... master/bin
by blubb
Fri Jan 12, 2018 10:52 pm
Forum: ESP8266 HDK
Topic: FCC problem - Spectrum analyzer shows unwanted transmission when startup
Replies: 11
Views: 329

Re: FCC problem - Spectrum analyzer shows unwanted transmission when startup

I recommend opening an issue on github
https://github.com/espressif/ESP8266_NONOS_SDK/issues

Edit:
There are several APIs like
system_phy_set_powerup_option(...);
system_phy_freq_trace_enable(...);
But if the problem occurs before user_rf_pre_init this is a case for a github issue for sure.
by blubb
Fri Jan 12, 2018 6:08 pm
Forum: ESP8266 HDK
Topic: FCC problem - Spectrum analyzer shows unwanted transmission when startup
Replies: 11
Views: 329

Re: FCC problem - Spectrum analyzer shows unwanted transmission when startup

Do you call this API in user_rf_pre_init or in user_init? I wonder if that makes a difference.
by blubb
Sun Dec 24, 2017 12:56 am
Forum: ESP8266 SDK
Topic: Limit WiFi channels for FCC compliance
Replies: 2
Views: 155

Re: Limit WiFi channels for FCC compliance

Oh, and I think the FCC limits are channels 1 to 11 (not 12).
by blubb
Wed Dec 20, 2017 12:24 am
Forum: ESP8266 SDK
Topic: Limit WiFi channels for FCC compliance
Replies: 2
Views: 155

Re: Limit WiFi channels for FCC compliance

Have you tried this?

Code: Select all

wifi_country_t wc = {.cc="USA", .schan=1, .nchan=12, .policy=WIFI_COUNTRY_POLICY_AUTO};
wifi_set_country(&wc);


Edit: Please report if it worked and if calling it in user_init is enough. Otherwise try putting it in user_rf_pre_init, I guess.
by blubb
Thu Dec 14, 2017 8:00 pm
Forum: ESP8266 SDK
Topic: Does anyone have an HTTPS server running?
Replies: 5
Views: 453

Re: Does anyone have an HTTPS server running?

The new SDK works when limited to only 1 connection, yes. Thanks. However, I gave up the endeavor since it does not work with standard browsers. They need more connections. There is too little heap in those tiny chips I'm afraid.
by blubb
Fri Dec 01, 2017 5:11 am
Forum: ESP8266 SDK
Topic: spi_flash_erase_sector() speed
Replies: 1
Views: 110

Re: spi_flash_erase_sector() speed

I just repeated your experiment using system_get_time(). Here, spi_flash_erase_sector() takes about 70 ms most of the time. Sometimes it is quicker (40 ms), though.
by blubb
Mon Nov 13, 2017 5:40 pm
Forum: ESP8266 SDK
Topic: bootv1.7.bin BUG
Replies: 3
Views: 356

Re: bootv1.7.bin BUG

I have experimented a lot and I found out it is best to rely on system_get_userbin_addr() and not system_upgrade_userbin_check(). No problems since then. Before that, I had cases when system_upgrade_userbin_check() was 1 (== bin2) and system_get_userbin_addr() was 0x1000... I flashed starting from 0...
by blubb
Mon Nov 13, 2017 5:26 pm
Forum: ESP8266 SDK
Topic: Auto light sleep doesn't seem to work with 2.1.x NONOS SDK
Replies: 3
Views: 284

Re: Auto light sleep doesn't seem to work with 2.1.x NONOS SDK

A while ago, I had the same question. http://bbs.espressif.com/viewtopic.php?f=7&t=5680 As I understand it, in light sleep mode the clock is off and the esp only wakes up periodically because of the beacons of an ap the esp is connected to. If there is no ap, it oversleeps. I stopped using light...

Go to advanced search