【Feedback】Can not hide SSID when Esp8266 in AP mode

Nkonnect
Posts: 3
Joined: Thu Jul 21, 2016 3:19 pm

【Feedback】Can not hide SSID when Esp8266 in AP mode

Postby Nkonnect » Thu Jul 21, 2016 3:36 pm

Hello,

While configuring ESP8266 in softAP mode i am using this AT command
AT+CWSAP=<ssid>, <pwd>, <chl>, <ecn>[, <max conn>][, <ssid hidden>]
where <ssid hidden> parameter is set to 1 (i.e do not broadcast SSID of ESP8266 soft-AP) .Response to this command is OK but still when i searched for available APs in my phone it shows SSID of configured ESP8266. All this happens on SDK Version:0.9.5(b1) firmware version.

Guide me to solve this issue.

Thanks
Nkonnect

ESP_Rubin
Posts: 222
Joined: Wed Jun 29, 2016 11:59 am

Re: Can not hide SSID when Esp8266 in AP mode

Postby ESP_Rubin » Thu Jul 21, 2016 7:21 pm

Hi,
could you update the AT to our latest version, everything is ok as i tried

Nkonnect
Posts: 3
Joined: Thu Jul 21, 2016 3:19 pm

Re: Can not hide SSID when Esp8266 in AP mode

Postby Nkonnect » Thu Jul 21, 2016 9:12 pm

hi esp_rubin,

i updated the module with this version AT version:0.50.0.0(Sep 18 2015 20:55:38) SDK version:1.4.0 and it worked fine, now the ssid is hidden. But the connection gets lost most of the time when sending data using AT+CIPSEND command it gives this msg
AT+CIPSEND=0,10

OK
>
Recv 10 bytes


busy s...
0,CONNECT FAIL
SEND FAIL

which is not acceptable in my application. Can u please send me a link for latest firmware, in which AT+CIPSEND command SEND FAIL issue is solved so that i can try with that

Thanks
Nkonnect

ESP_Rubin
Posts: 222
Joined: Wed Jun 29, 2016 11:59 am

Re: Can not hide SSID when Esp8266 in AP mode

Postby ESP_Rubin » Fri Jul 22, 2016 4:32 pm

hi sir,
please find as link:http://bbs.espressif.com/viewtopic.php?f=46&t=2451

Nkonnect
Posts: 3
Joined: Thu Jul 21, 2016 3:19 pm

Problem with the latest firmware

Postby Nkonnect » Fri Jul 22, 2016 8:39 pm

hi esp_rubin,
I upgrade my smart wifi module with the firmware given on this link //bbs.espressif.com/viewtopic.php?f=46&t=2451 as suggested by you, but when i restart this module it gives me garbage at all baud rates, not a single AT command works also the serial BLUE LED always remains ON. I updated firmware for 8Mbit flash for both BOOT and NON BOOT mode.
Can you tell me where m going wrong?




Thank you
Nkonnect

Sd123
Posts: 1
Joined: Sun Jan 15, 2017 5:37 am

Re: 【Feedback】Can not hide SSID when Esp8266 in AP mode

Postby Sd123 » Sun Jan 15, 2017 5:43 am

Hello, I am very new to ESP8266. Can you please guide me in details about how to update the firmware of the ESP8266 to the latest? Actually, I want the SSID of ESP8266 to be hidden and I came across a few articles that say I need the latest firmware for that. I had tried updating the firmware with a software named "Realterm" but couldn't do it successfully. Please help.

Who is online

Users browsing this forum: Bing [Bot] and 3 guests