ESP8266 does not receive data correctly

Wenkangl
Posts: 2
Joined: Thu Mar 16, 2017 8:18 am

ESP8266 does not receive data correctly

Postby Wenkangl » Thu Mar 16, 2017 1:39 pm

Hi, there

As shown in the figure, my program sent 2048 bytes every second automatically, but only the first packet are received correctly by esp8266. And as is observed data was sent before esp8266 echo back 'ok', although the I received "send ok" after that. An instant question for this is: how long does it take for esp8266 to execute the command? and how long will it cost for esp8266 to send all these 2048 bytes of data? Another question based on this observation is why esp8266 only received 1965 bytes of data while the actual amount of data sent via serial port to esp8266 is 2048 bytes?

>> AT Command and Data sent
commands.png


>> Data received at TCP Server
received.png


Cheers,

WL

User avatar
pratik
Posts: 361
Joined: Wed Jun 29, 2016 7:17 pm
Location: India
Contact:

Re: ESP8266 does not receive data correctly

Postby pratik » Thu Mar 30, 2017 12:44 am

Are you using the latest AT command firmware?
Also, what happens if you send the 2048 bytes as packets of 2 x 1024 bytes packages?

I would recommend using shorter send lengths as long packets may take time to send if network conditions are not good (retransmisisons).
Also, secure connections will have limits on how much data you can send at a time.
Are you using a secure connection?
Regards,
Pratik Panda
Website: http://www.PratikPanda.com

Custom firmware, Knowledge base and freelancing (ESP8266/ESP32):
http://www.iot-bits.com

Who is online

Users browsing this forum: No registered users and 3 guests