ESP-01- SoftAP / TCP Server-10Hz ?

Olfox
Posts: 5
Joined: Fri Apr 14, 2017 6:52 am

ESP-01- SoftAP / TCP Server-10Hz ?

Postby Olfox » Fri Apr 14, 2017 7:05 am

Hi,

My project use an android tablet. It is connected to my ESP Soft AP.

My Android application opens the socket on 192.168.4.1 , port 333.
It sends a 'R' to request data each 200ms to my ESP, connected to my Arduino mega with 115200baud UART.

Arduino read in loop the uart buffer. if 'R' is received, it sends my data (from 100 to 1200 bytes).

I see by using counter that all the request are not passing.

I also see in documentation that we have to wait 1 sec between each AT COMMAND ( CIPSEND in my case).

Is it posible to go faster ?

I wanted to use transparent mode but for this you need to be in Single mode, not a rela problem. But once you are in signle mod, you can't start the TCP server... what interested me because i want esp to be the server.

Situation seems to be bloked no?

Do you have an idea to have the maximum speed between my android nd my arduino by using AT command please?

Thanks a lot for you support i appraciate it a lot :)

Her Majesty
Posts: 186
Joined: Mon Oct 27, 2014 11:09 am

Re: ESP-01- SoftAP / TCP Server-10Hz ?

Postby Her Majesty » Mon Apr 17, 2017 2:57 pm

If the sending finished, it will response "SEND OK" or "SEND FAIL", then you can send the next packet or retry the current one.

Olfox
Posts: 5
Joined: Fri Apr 14, 2017 6:52 am

Re: ESP-01- SoftAP / TCP Server-10Hz ?

Postby Olfox » Mon Apr 17, 2017 5:54 pm

Thanks Majesty for the reply.

Did you try it yourself?

Its seems its the fastest way to be at maximum speed.

But i tried to do my own code. Just start ESP as UDP server.

And transfert on serial udp received, then transmit on udp the Serial answer received, and it seems i also really limited with the period. around one second its ok , but faster it begins to not response sometimes... I flash it with arduino IDE, does it mean behind, the code is only reading Serial each second like the datasheet mentionned, even if in my code i'm looping for reception on serial?

Who is online

Users browsing this forum: No registered users and 3 guests