Part failure in TX_POWER_BACKOFF

ByronLee
Posts: 5
Joined: Thu Jul 28, 2016 11:27 am

Part failure in TX_POWER_BACKOFF

Postby ByronLee » Mon Aug 08, 2016 11:57 am

我用ESP_FACTORY_TEST_TOOL_V4.9.5测试时,总是出现Part failure in TX_POWER_BACKOFF错误信息,配置文件和log信息如下:
配置文件:

Code: Select all

#define   CHIP_TYPE_1            ESP8266   #ESP8089 or ESP8266
#define   LOG_PATH_1            ./logs      #log saving path, user could modify their own folder
#define  FACTORY_INFO_1     ESP     #fill factory id or factory name
#define   COMPORT_1       9
#define   BAUDRATE_1      115200   #26m晶振需要减小波特率(230600)
#define   IMGPATH_1       ./image/eagle.app.flash_MODULE_TEST_26m_tout_151229.bin
#define   FREQ_1          26             #晶振频率

#define   AUTOSTART_1     0              #1:自动开始下一次测试 0:手动开始 

#define   INSTRUMENT_EN_1   0          #使能仪器测试模式
#define   IPADDR_IQV_1        192.168.100.254    #iqview 仪器IP地址
#define   IPADDR_PC_1        192.168.100.186     #PC IP地址
#define   TESTER_1        LITEPOINT     #不要更改
#define   RFPORT_1        1    #1:left  2:right

#define   INPUT_ATTEN_EN_1   1  #use input path loss to test tx
#define   PATH_ATTEN_1   21    #practical attenuation in the path
#define   PATH_ATTEN_DIFF_ALARM_1   5  #固定 设置线路衰减与计算值的最大偏差 超过会报错提示
#define   PATH_ATTEN_TX_CRT_1      0    #CORRECT VAL FOR TX GAIN
#define   PATH_ATTEN_CAL_CHANNEL_1   1,6,11,14   #CALCULATE PATH ATTEN IN THIS CHANNEL

#define   PRINT_MAC_EN_1   1   #set 1 to print MAC after
#define   PRINT_MAC_AUTO_1   0   #set 1 to print MAC automatically
#define   PRINT_MAC_COMMAND_1   ./mac_printer/8266_MAC2DPrint.exe 


#define   UPLOAD_CMD_PATH_1      ./result_upload/ADS_8266.exe
#define   UPLOAD_SN_RES_EN_1    1    #enable upload test result and SN
#define   UPLOAD_SN_LENGTH_1      12   #length of SN string
#define   UPLOAD_SN_AUTO_START_1   1   #输入满UPLOAD_SN_LENGTH长度的SN号后,自动开始测试,重启或者点击开始后下次生效



#define   ANALOGTEST_1    1
#define   TXTEST_1        1
#define   RXTEST_1        1
#define   SKIP_DOWNLOAD_1  0

#define   SET_MAC_EN_1    0          #support burn customer Mac
#define   MAC_INPUT_EN_1    0
#define   MAC_CRC_EN_1    0
#define   MAC_OFFSET_1    0x7c000            # mac burn addr
#define   MAC_START_1     A00000000000   #mac start addr
#define   MAC_END_1        A00000000008    #mac end addr
#define   MAC_CURRENT_1  A00000000000 


#define   DEBUG_EN_1        1
#define   ANTENNA_1         1           #1:天线测试 0:cable测试
#define   INITFROMXLS_1       0         #这项不要更改
#define   START_DELAY_1       200         #四个模块时间相互错开,单位ms

#define   GPIO_TEST_EN_1     0
#define   GPIO_TEST_PIN_1    0x3030
#define   GPIO_TEST_VAL_1    0x1010

#define   GPIO_TEST_READ_EN_1     0
#define   GPIO_TEST_VAL_TARGET_1  0x3030


#define   ADC_TEST_EN_1     0

#define   EFUSE_MODE_1      1    # 0: NOT USED ; 1:NORMAL
#define  USER_FW_DOWNLOAD_EN_1    0   #0: disable ; 1: enable
#define  USER_FW_DOWNLOAD_PORT_1   SPI   #SPI OR HSPI
#define  USER_FW_FORCE_DOWNLOAD_1    0  #0:download if RF test pass ; 1:download after test
#define  USER_FW_VER_TEST_EN_1    0   #0: disable ; 1: uart 2: gpio
#define  USER_FW_VER_STR_1        v1.0.02

#define  USER_FW_FILE_NUM_1       1
#define  USER_FW_PATH0_1        ./bin/test.bin
#define  USER_FW_ADDR0_1        0x0
#define  USER_FW_PATH1_1        ./bin/test.bin
#define  USER_FW_ADDR1_1        0x0

#user fw version, when system restart print : esp_user_fw_version:xxxx
#define  USER_TEST_CMD_EN_1       0  #Send user test command
#define  USER_TEST_CMD_NUM_1      2  #TEST COMMAND NUMBER

#define  USER_TEST_CMD0_1      AT+CWLAP\r\n
#define  USER_TEST_RESP0_1     OK
#define  USER_TEST_TIMEOUT0_1    5   #S
#define  USER_TEST_CMD1_1      AT+CWLAP\r\n
#define  USER_TEST_RESP1_1     OK
#define  USER_TEST_TIMEOUT1_1    5   #S
#define  USER_TEST_CMD2_1      AT+CWJAP\r\n
#define  USER_TEST_RESP2_1     OK
#define  USER_TEST_TIMEOUT2_1    5   #S


log信息:

Code: Select all

TOOL_VERSION: 4.9.5

FACTORY: esp

MODULE_TEST START!!!

phy_version: 20130913_b1 Dec 29 2015 11:51:10

CHIP_VERSION: 0x0

CHIP_ID: 0x5ccf7f64



rc_cal_dout=29, rx_filt_dcap=14, tx_filt_dcap=23

vdd33=3379, temp_code=0, offset=0

cal_rf_ana_gain, rf_gain=0x1f, ana_gain=0x10, bb_atten=6

rxiq_tot_pwr1=33dB, k=0

RX_NOISEFLOOR, -388

RX_NOISEFLOOR, -386

RX_NOISEFLOOR, -392

RX_NOISEFLOOR, -392

TXCAP_TMX2G_CCT_LOAD, 13, 15, 15,

TXCAP_PA2G_CCT_STG1, 3, 3, 1,

TXCAP_PA2G_CCT_STG2, 2, 1, 1,

TX_POWER_BACKOFF, 9, 10, 11, 10,

TX_PWRCTRL_ATTEN, -24, -4, 7, 13, 17, 26, -23, -3, 8, 15, 19, 27, -22, 4, 9, 15, 20, 28, -23, -4, 7, 14, 18, 27,

TXIQ, 4, 12

TXDC, 79, 77; 78, 69; 78, 67; 78, 66;

RXIQ, 0, -1; 0, -2; 1, -2; 1, -2; 1, -2;

RXDC, 257, 251, 256, 256; 257, 252, 256, 256; 258, 252, 256, 256; 258, 252, 256, 256; 257, 252, 256, 256; 258, 252, 256, 256; 259, 253, 256, 256; 259, 253, 256, 256; 259, 254, 256, 253; 258, 254, 258, 253; 259, 253, 256, 256; 259, 254, 256, 256; 260, 254, 256, 256; 260, 254, 256, 256; 260, 254, 256, 256; 260, 254, 253, 256; 259, 254, 256, 256; 259, 254, 256, 256; 259, 254, 256, 255; 259, 254, 256, 256; 260, 254, 251, 257; 259, 254, 256, 256; 259, 254, 256, 256; 259, 254, 256, 256; 259, 254, 256, 255; 259, 254, 256, 256; 260, 254, 251, 257; 259, 254, 256, 256; 259, 254, 256, 256; 259, 254, 256, 256;

SVN_LOG=772

TX_VDD33=3379

TOUT=13

TEST_NUM=1, TEST_TIME=436172us



MODULE_ANA TEST END!!!



tx packet test ..

txp_pwctrl_atten: 3

rombist_rslt: 0

fb_rxrssi: 55, 55, 54, 53, 52, 53,

dut_rxrssi: 61, 61, 61, 61, 61, 61,

fb_rx_num: 14, 14, 16, 15, 16, 16,

dut_rx_num: 14, 14, 16, 15, 16, 16,

FREQ_OFFSET, -13, -12, -13, -13,

txp_state: 0xffffffffdffffffff77fb7ff, 0xffffffffdffffffff77fb7ff;

txp_result: 91, 91, 0

0: req_suc:1 req_times:1 data_suc:1 txdata_use_timer:0x636f 96 txreq_start_time:0x72694b txdata_start_time:0x761307

init_time=402935us



MODULE_TEST END!!!

======================

EFUSE LOG:

---------------

REG0:6A5A0000

REG1:02008218

REG2:6400b000

REG3:005CCF7F

----------------

====================

EFUSE NORMAL MODE

====================

EFUSE CHECK PASS...-------------------------



TOOL_VERSION: 4.9.5

FACTORY: esp

logs here:
Part failure in TX_POWER_BACKOFF  #0,#0 : 0.000000 !< 9.000000 !< 8.000000 
 Part failure in TX_POWER_BACKOFF  #0,#1 : 0.000000 !< 10.000000 !< 8.000000 
 Part failure in TX_POWER_BACKOFF  #0,#2 : 0.000000 !< 11.000000 !< 8.000000 
 Part failure in TX_POWER_BACKOFF  #0,#3 : 0.000000 !< 10.000000 !< 8.000000

Espressif_Kelly
Posts: 140
Joined: Mon Oct 27, 2014 10:40 am

Re: Part failure in TX_POWER_BACKOFF

Postby Espressif_Kelly » Mon Sep 12, 2016 7:38 pm

您好!

请问贵司模块使用的是何种天线?是否有进行过阻抗匹配。

谢谢!

Espressif_Kelly
Posts: 140
Joined: Mon Oct 27, 2014 10:40 am

Re: Part failure in TX_POWER_BACKOFF

Postby Espressif_Kelly » Wed Sep 14, 2016 1:45 pm

Hi,

补充说明:

测试时,是否是由于测试工装或者环境影响了 PCB 天线。

比如测试 PCB 天线被测试工装包起来了,与测试信号板之间有遮挡,这也会导致 back_off 增高。

请尝试手动焊线把模组裸露出来进行测试再观察一下测试数据。

如有问题,请反馈给我们。

谢谢!

Who is online

Users browsing this forum: No registered users and 6 guests