Radio section failing on chips

stephen-tek
Posts: 2
Joined: Fri May 26, 2017 7:11 pm

Radio section failing on chips

Postby stephen-tek » Fri May 26, 2017 7:20 pm

We developed a product using the ESP8266 approx 12 months ago and have thousands of units sold to date, However we are now starting to get returns from the field with radio failures.

Upon analysis of the returns the WiFi modules are the cause of the returns. Lifting the can from the modules and swapping the flash chip does not solve the issue so it is definitely an issue with the ESP chip.

Sending AT commands to the ESP chip works fine and it responds as normal, When searching for networks it always finds 0 networks and entering the parameters of a known network to connect too also fails.

All of these units have been tested and worked fine but within a few months the radio seems to be failing.

I have tried erasing the chip completely and loading the latest firmware but it again made no difference.

Any ideas would be great as this is a major concern for us going forward...

YimingLi
Posts: 50
Joined: Sun May 03, 2015 5:36 pm

Re: Radio section failing on chips

Postby YimingLi » Sat May 27, 2017 10:28 am

Hi,

Have you checked (1) whether the pin 2 and pin 31 are still solder well and (2) whether the rf frequency is still calibrated well. The (2) might be the more possible cause. Possibly your crystal circuit is not good enough and has much more frequncy drift due to aging. You may have a try to replace the crystal but keep other parts untouched. Also check how your rf calibration machanism is implemented from the rf_settings. Please refer to the section of 6.3.3 from the document "2a-esp8266-sdk_getting_started_guide" for more detail on how to implement a correct rf calibration machanism. If you have done these, then you may please connect forcedly to an exsiting ap via AT command to see whether it could connect successfuly. If connect, then scan the signal again.

Hope above would be helpful for you.

-----------------------------------------------------------------------------------------------------
A WIFI module based on ESP8266 providing an effective throughput over MBytes/s
eBay: http://www.ebay.com/itm/282255354664
taobao: http://item.taobao.com/item.htm?id=550946928238

Yiming

stephen-tek
Posts: 2
Joined: Fri May 26, 2017 7:11 pm

Re: Radio section failing on chips

Postby stephen-tek » Mon May 29, 2017 7:07 pm

Hi,

Looks like you are spot on, I swapped the crystal with a known good unit and it started working perfectly. I am currently working on generating new files to see if i can adjust the offset so we do not have to modify the hardware in the current units out in the field. Is it possible to modify the offset using AT Commands?

Thanks,

Who is online

Users browsing this forum: No registered users and 1 guest