Baud Rate Change Attempt Bricks ESP-01

Joe WeatherBalloon
Posts: 4
Joined: Fri Jun 16, 2017 7:59 am

Baud Rate Change Attempt Bricks ESP-01

Postby Joe WeatherBalloon » Fri Jun 16, 2017 8:15 am

Greetings!

I experimented with my ESP8266 ESP-01 through Termite and verified I was able to connect to my test device. After a second verification, I investigated methods to drive the ESP-01 through an Arduino Pro Mini. The Pro Mini has a single UART. Thinking I would need to monitor the ESP-01 communications, I thought I would use SoftwareSerial for the ESP-01 and use the UART to show communications through the Serial Monitor. In order to use SoftwareSerial with the ESP-01, I needed to change the baud rate from 115200 (default) to something under 57600; I chose 9600.

I don't recall if I used AT+CIOBAUD=9600 or AT+IPR=9600. The end result was the output from the ESP-01 was not readable.

I researched the issue and found many ideas. Re-flashing the ESP-01 seemed the most common. I put together a flashing circuit and, according to the flashing program, successfully re-flashed the ESP-01 (four bin files). The output was still not readable. I tried flashing ESP_8266_BIN0.92.bin and the output was still not readable. One suggestion was to connect TX to RX together and connect the power for two minutes. After the last experiment, I am unable to flash the ESP-01.

I suspect my ESP-01 has entered the realm of an amusing conversation piece but I would like some confirmation. Thoughts?

Lastly, what is a safe method of changing the baud rate on an ESP-01?

Thanks!
Joe

User avatar
pratik
Posts: 460
Joined: Wed Jun 29, 2016 7:17 pm
Location: India
Contact:

Re: Baud Rate Change Attempt Bricks ESP-01

Postby pratik » Fri Jun 16, 2017 2:09 pm

One suggestion was to connect TX to RX together and connect the power for two minutes.

I hope you didn't do this, its never a good idea and can kill a lot of MCUs that have totem pole outputs.

By the way, did you try baud rate of 74880 to see what the ESP8266 is printing out?
Regards,
Pratik Panda
Website: http://www.PratikPanda.com

Custom firmware, Knowledge base and freelancing (ESP8266/ESP32):
http://www.iot-bits.com

Joe WeatherBalloon
Posts: 4
Joined: Fri Jun 16, 2017 7:59 am

Re: Baud Rate Change Attempt Bricks ESP-01

Postby Joe WeatherBalloon » Sat Jun 17, 2017 3:17 am

pratik wrote:By the way, did you try baud rate of 74880 to see what the ESP8266 is printing out?


Hello Pratik!

Thanks for the prompt reply! Unfortunately, I did connect Tx to Rx. The claim was it brought back two ESP-01s. It is, of course, one of my more boneheaded moves but nothing else corrected the issue.

I have placed an order to replace the ESP-01.

Regarding your question about a specific baud rate - I tried available (i.e., available from a droplist) baud rates from 9600 and up with no readable responses. How did you arrive at 74880? It might be something I try if this issue occurs again.

Thanks!
Joe

Who is online

Users browsing this forum: No registered users and 1 guest