Esp8266 can not stable connect to HuaWei Router Honor WS851

leif_sxl
Posts: 4
Joined: Tue Sep 27, 2016 3:11 pm

Esp8266 can not stable connect to HuaWei Router Honor WS851

Postby leif_sxl » Tue Sep 27, 2016 3:27 pm

I used the latest RTOS SDK, and it is not stable that esp8266 connect to WS851 . In most times, firmware will reply the failure reason as REASON_AUTH_EXPIRE and disconnect then. For most router, it looks like work well. So I guess my code is ok.

Is there any potential bug in SDK or compatible issue?

Pls. find the router introduction in the following link: http://www.vmall.com/product/3053.html

User avatar
pratik
Posts: 416
Joined: Wed Jun 29, 2016 7:17 pm
Location: India
Contact:

Re: Esp8266 can not stable connect to HuaWei Router Honor WS851

Postby pratik » Fri Sep 30, 2016 6:22 pm

Hello,

If you are using one of the latest SDKs (released in July or later), you should be having SDK bugs.
Did you try connecting to the router in open mode? (No network passkey)
Regards,
Pratik Panda
Website: http://www.PratikPanda.com

Custom firmware, Knowledge base and freelancing (ESP8266/ESP32):
http://www.iot-bits.com

leif_sxl
Posts: 4
Joined: Tue Sep 27, 2016 3:11 pm

Re: Esp8266 can not stable connect to HuaWei Router Honor WS851

Postby leif_sxl » Thu Jan 05, 2017 6:45 pm

hi, pratik,

Thank your reply!

But I have to say this issue looks like still exist after updated to the latest RTOS sdk. Although it happen not very often like before.

Pls. check my log print, Huawei-RongyaoProTest is my ssid for test:

disconnect from ssid Huawei-RongyaoProTest, reason 2


B.R.
Si Xiaolei

leif_sxl
Posts: 4
Joined: Tue Sep 27, 2016 3:11 pm

Re: Esp8266 can not stable connect to HuaWei Router Honor WS851

Postby leif_sxl » Fri Jan 06, 2017 11:00 am

And one more words. there are two kinds of reason report when fail connect to router:

Code: Select all

REASON_AUTH_EXPIRE
REASON_ASSOC_EXPIRE


Could you help to check this ?

User avatar
pratik
Posts: 416
Joined: Wed Jun 29, 2016 7:17 pm
Location: India
Contact:

Re: Esp8266 can not stable connect to HuaWei Router Honor WS851

Postby pratik » Fri Jan 20, 2017 1:45 pm

Still seems like a router setup issue to me. I don't have any cases where the ESP8266 will disconnect with this reason, so I am unable to reproduce this issue on my end.
How is your router authentication set up?

Reason 2 is AUTH_EXPIRE. This is being caused from the router end I think.
Regards,
Pratik Panda
Website: http://www.PratikPanda.com

Custom firmware, Knowledge base and freelancing (ESP8266/ESP32):
http://www.iot-bits.com

Who is online

Users browsing this forum: No registered users and 1 guest