Esp8266 can not stable connect to HuaWei Router Honor WS851

leif_sxl
Posts: 4
Joined: Tue Sep 27, 2016 3:11 pm

Esp8266 can not stable connect to HuaWei Router Honor WS851

Postby leif_sxl » Tue Sep 27, 2016 3:28 pm

I used the latest RTOS SDK, and it is not stable that esp8266 connect to WS851 . In most times, firmware will reply the failure reason as REASON_AUTH_EXPIRE and disconnect then. For most router, it looks like work well. So I guess my code is ok.

Is there any potential bug in SDK or compatible issue?

Pls. find the router introduction in the following link: http://www.vmall.com/product/3053.html

mash
Posts: 5
Joined: Thu Feb 04, 2016 12:30 am

Re: Esp8266 can not stable connect to HuaWei Router Honor WS851

Postby mash » Sun Feb 12, 2017 8:03 pm

I'm seeing a similar issue with another router.

My issue is:

1. ESP8266 is successfully connected to router
2. Power off -> Power on
3. ESP8266 is successfully connected to router
4. Power off -> Power on
5. sometimes, we see:

in the callback we pass to wifi_set_event_handler_cb,
evt->event_id == EVENT_STAMODE_DISCONNECTED and evt->event_info.disconnected.reason == REASON_AUTH_EXPIRE
is met and while ESP8266 tries to reconnect to the same router,
this occurs repeatedly, until some random time when it successfully connects again.

The router I'm using is MZK-MF300N3 from PLANEX.
Anyone seeing a similar issue?
Is this a known issue and fixed somehow?

vad7
Posts: 4
Joined: Sun Feb 07, 2016 7:10 pm

Re: Esp8266 can not stable connect to HuaWei Router Honor WS851

Postby vad7 » Wed Mar 08, 2017 2:26 pm

The same issue with routers Linksys EA4500 and Zyxel Keenetic II.
With Mikrotik works fine.

Debug:
state: 5 -> 2 (4c0)
rm 0
WiFi event(1): Disconnect from ssid wifi1, reason(4): Assoc_expire, count 1

Who is online

Users browsing this forum: No registered users and 2 guests