user_uart_wait_tx_fifo_empty

francis
Posts: 5
Joined: Thu Jan 12, 2017 12:42 am

user_uart_wait_tx_fifo_empty

Postby francis » Wed Mar 15, 2017 3:01 am

hi,
im trying to use the ESP12E with arduino IDE.
i have connected everything fine i guess.
using a 1000uF capa & a 0,1uF capa between GND & VCC.
i also used 10k resistors to pull up and down.

i managed to upload the WiFiScan example.
but when i lauch in normal mode (GPIO0 to High), i got this message :

Code: Select all

load 0x4010f000, len 1384, room 16
tail 8
chksum 0x2d
csum 0x2d
v09f0c112
~ld
Fatal exception (0):
epc1=0x40218354, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000
Fatal exception (0):
epc1=0x40218354, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000
Fatal exception (0):
epc1=0x40218354, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000
Fatal exception (0):
epc1=0x40218354, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000
Fatal exception (0):
epc1=0x40218354, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000
Fatal exception (0):
epc1=0x40218354, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000
Fatal exception (0):
epc1=0x40218354, epc2=0x00000000, epc3=0x00000000, excvaddr=0x00000000, depc=0x00000000


When i look at the adress 0x40218354, it seems this is due to a

Code: Select all

user_uart_wait_tx_fifo_empty
!

Can you tell me what i got to do ?
i forgot to mention, i have a IPS 3610D as power supply, configured to provide 3.5v.
my parameters for Arduino IDE are :

Code: Select all

Generic ESP8266 Module
QIO
Flash Frequency 80Mhz
CPU Frequency 80Mhz
Flash size 4MB with 1MB for SPIFFS
debug port : serial
debug level : none
reset method ck
upload speed 115200
programator : AVRIsp mkll (i also tried AVRIsp and USBasp)


This would be important because i want to embed the ESP12e for my clients.
Thank you.

Who is online

Users browsing this forum: Google [Bot] and 11 guests