missing +ipd

vichu537
Posts: 2
Joined: Mon Jun 26, 2017 2:17 pm

missing +ipd

Postby vichu537 » Mon Jun 26, 2017 2:25 pm

hi, I'm using my esp8266 module as a TCP server. when sending data from multiple client devices it oftenly shows data missing, In that cases +ipd is missing in my received data. expecting your valuable suggetions and solutions on this issue.
My settings are as follows:

AT+CWMODE=1
AT+CWDHCP=0,0
AT+CIPSTA="STA_IP","GATEWAY","SUBNET MASK"
AT+CWJAP="SSID","PASS_WORD"
AT+CIPMUX=1
AT+CIPSERVER=1,2000 I'M USING PORT 2000
AT+CIPSTO=0

AFTER the setting , client devices starts connect to the server device and sends data.. the +ipd missing occures when data receives from multiple clients...........please help me to resolve this issue...

Her Majesty
Posts: 191
Joined: Mon Oct 27, 2014 11:09 am

Re: missing +ipd

Postby Her Majesty » Wed Jun 28, 2017 3:42 pm

In some cases, for example, bad network environment, TCP may combine 2 packets to be 1 packet, but the data should never missing.

Code: Select all

+IPD,<length>:xxxxxx

You can check whether the <length> is correct or not. For example, maybe you sent 2 packets of which length is 6, but what you got is a +IPD with length 12, that is normal, not a bug. It combines 2 packets to be 1.

vichu537
Posts: 2
Joined: Mon Jun 26, 2017 2:17 pm

Re: missing +ipd

Postby vichu537 » Tue Aug 01, 2017 3:21 pm

Her Majesty wrote:In some cases, for example, bad network environment, TCP may combine 2 packets to be 1 packet, but the data should never missing.

Code: Select all

+IPD,<length>:xxxxxx

You can check whether the <length> is correct or not. For example, maybe you sent 2 packets of which length is 6, but what you got is a +IPD with length 12, that is normal, not a bug. It combines 2 packets to be 1.

hi,
thanks for the replay. But the data missing issue still exist in some rare events..

Who is online

Users browsing this forum: No registered users and 3 guests