【Feedback】ShowCritical:0 ??

mash
Posts: 5
Joined: Thu Feb 04, 2016 12:30 am

【Feedback】ShowCritical:0 ??

Postby mash » Tue May 31, 2016 6:32 pm

I'm seeing this in the logs just before resetting, while doing some heavy crypt calculations.

ShowCritical:0

ets Jan 8 2013,rst cause:4, boot mode:(3,6)

wdt reset
load 0x40100000, len 1856, room 16
tail 0
chksum 0x63
load 0x3ffe8000, len 776, room 8
tail 0
chksum 0x02
load 0x3ffe8310, len 552, room 8
tail 0
chksum 0x79
csum 0x79

2nd boot version : 1.5
SPI Speed : 40MHz
SPI Mode : QIO
SPI Flash Size & Map: 32Mbit(1024KB+1024KB)
jump to run user1 @ 1000


What does this mean? And how can we avoid this?
I'm using the latest 1.4.0 RTOS SDK.

ESP_Rubin
Posts: 222
Joined: Wed Jun 29, 2016 11:59 am

【Feedback】Re: ShowCritical:0 ??

Postby ESP_Rubin » Thu Jun 30, 2016 3:37 pm

sorry, i never reproduce this issue on my board, maybe you can mark the print in ./third_party/freertos/port.c:314: ets_printf("ShowCritical:%d\n",uxCriticalNesting);

mengzawj
Posts: 24
Joined: Mon Feb 01, 2016 12:06 am

Re: 【Feedback】Re: ShowCritical:0 ??

Postby mengzawj » Wed May 17, 2017 11:06 pm

ESP_Rubin wrote:sorry, i never reproduce this issue on my board, maybe you can mark the print in ./third_party/freertos/port.c:314: ets_printf("ShowCritical:%d\n",uxCriticalNesting);



I have run into the same problem,any suggestions?

Code: Select all

[2017-05-17 22:55:32.784 R]ShowCritical:0

[2017-05-17 22:55:33.190 R]
 ets Jan  8 2013,rst cause:2, boot mode:(3,6)

load 0x40100000, len 31268, room 16
tail 4
chksum 0xe1
load 0x3ffe8000, len 2240, room 4
tail 12
chksum 0x70
ho 0 tail 12 room 4
load 0x3ffe88c0, len 1264, room 12


This problem sometimes arise,and no other exceptions!

Star
Posts: 2
Joined: Fri Aug 11, 2017 3:08 pm

Re: 【Feedback】ShowCritical:0 ??

Postby Star » Thu Aug 24, 2017 4:25 pm

in freerots/port.c found below

Code: Select all

/* Each task maintains its own interrupt status in the critical nesting
variable. */
static unsigned portBASE_TYPE uxCriticalNesting = 0;


i guess appear this “ShowCritical:0” because Called a function that should not be called in task

My condition is to open the software timer in the task the timer calls the nopoll_conn_send_text () function so "ShowCritical 0" appears but I call the nopoll_conn_send_text () function in the queue's callback function Then my program is normal and normal operation

ritesh
Posts: 29
Joined: Thu Nov 05, 2015 4:32 pm
Location: India
Contact:

Re: 【Feedback】ShowCritical:0 ??

Postby ritesh » Sun Sep 10, 2017 1:27 am

Hi,

Did you find anything for your issues?

We are getting ShowCritical:1 issue and then Watchdog Reset after that in my application but we have used xTaskEnterCritical and xTaskExitCritical while writing data into SPI Flash memory.
Regards,
Ritesh Prajapati

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 3 guests