ESP hangs and doesnot respond to any input

magnetron
Posts: 9
Joined: Tue Nov 10, 2015 10:13 pm

ESP hangs and doesnot respond to any input

Postby magnetron » Tue Feb 28, 2017 10:23 pm

hello dear forum,

I use ESP8266 with STM32 uC to embed a webpage

everything is fine until suddenly ESP hangs and doesnot respond
to any input anymore

if I type for example 192.168.1.110:40024 at chrome browser
ESP doesnot send > character back
previous to this fault ESP send
UNLINK
ERROR

this time I want reset ESP and send AT+RST command
however ESP never respond

how can I handle this error ?
thanks

User avatar
pratik
Posts: 402
Joined: Wed Jun 29, 2016 7:17 pm
Location: India
Contact:

Re: ESP hangs and doesnot respond to any input

Postby pratik » Wed Mar 01, 2017 1:59 pm

This does not seem to be a common issue.
Can you specify details on this?
i.e. which firmware version are you using, your router and what is your phone sending along with the GET request?
Regards,
Pratik Panda
Website: http://www.PratikPanda.com

Custom firmware, Knowledge base and freelancing (ESP8266/ESP32):
http://www.iot-bits.com

magnetron
Posts: 9
Joined: Tue Nov 10, 2015 10:13 pm

Re: ESP hangs and doesnot respond to any input

Postby magnetron » Thu Mar 02, 2017 3:51 am

hello thank you

I use USrobotics ADSL modem router
=============================================
reset command response below
=============================================
ets Jan 8 2013,rst cause:1, boot mode:(3,0)

load 0x40100000, len 23200, room 16

tail 0

chksum 0x72

load 0x3ffe8000, len 948, room 8

tail 12

chksum 0x50

ho 0 tail 12 room 4

load 0x3ffe83b8, len 3888, room 12

tail 4

chksum 0x1d

csum 0x1d

rln
======================================
HTTP message from PC below
======================================
+IPD,0,551:POST / HTTP/1.1

Host: 192.168.1.110:40024

Connection: keep-alive

Content-Length: 19

Cache-Control: max-age=0

Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0
.8

Origin: http://192.168.1.110:40024

Upgrade-Insecure-Requests: 1

User-Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko)
Chrome/49.0.2623.112 Safari/537.36

Content-Type: text/plain

Referer: http://192.168.1.110:40024/

Accept-Encoding: gzip, deflate

Accept-Language: tr-TR,tr;q=0.8,en-US;q=0.6,en;q=0.4

O1=1

Submit

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest