ADC positive offset on 0V

gjump
Posts: 19
Joined: Thu Nov 24, 2016 6:24 am

ADC positive offset on 0V

Postby gjump » Tue Sep 12, 2017 2:10 am

I'm getting a very annoying problem: I have a project using esp12e and on some boards I got wrong ADC readings(using system_adc_read SDK 2.0.0 NONOS), even when I ground the ADC pin I can read a value ~10mV. I tried to change WiFi modes(all of them) but didn't changed significantly.
Any help is appreciated!

Regards,

ESP_Faye
Posts: 1623
Joined: Mon Oct 27, 2014 11:08 am

Re: ADC positive offset on 0V

Postby ESP_Faye » Tue Sep 12, 2017 2:10 pm

Hi,

Could you have a try with the latest ESP8266_NONOS_SDK?

Thanks for your interest in ESP8266!

gjump
Posts: 19
Joined: Thu Nov 24, 2016 6:24 am

Re: ADC positive offset on 0V

Postby gjump » Tue Sep 12, 2017 11:48 pm

ESP_Faye wrote:Hi,

Could you have a try with the latest ESP8266_NONOS_SDK?

Thanks for your interest in ESP8266!


Going to try that.

gjump
Posts: 19
Joined: Thu Nov 24, 2016 6:24 am

Re: ADC positive offset on 0V

Postby gjump » Wed Sep 13, 2017 3:56 am

ESP_Faye wrote:Hi,

Could you have a try with the latest ESP8266_NONOS_SDK?

Thanks for your interest in ESP8266!


Faye, same problem, same offset. I'll try on more boards, but I got 50% working and 50% with this problem and I'm always checking the voltage at the pin with a calibrated equipment to be sure.
Any thoughts?

Regards,

gjump
Posts: 19
Joined: Thu Nov 24, 2016 6:24 am

Re: ADC positive offset on 0V

Postby gjump » Thu Sep 14, 2017 9:36 pm

@ESP_Faye
Things i've tried:
Switched the ESPs between boards to to be sure that isn't the circuit, the problem followed the ESPs.
Wrote a simple code using system_adc_read_fast(), wifi off and got the same result, with the ADC pin grounded it reads 10-12 points.
Yesterday I've built 3 more boards, 2 ok and 1 with this offset. I have now 3 with offset and 4 working.

Don't know what's going on;

Regards,

Jamartox
Posts: 11
Joined: Tue Sep 12, 2017 2:09 am

View first unread post

Postby Jamartox » Fri Sep 15, 2017 5:40 pm

Dont you have the down arrow to the left of the thread title?

gjump
Posts: 19
Joined: Thu Nov 24, 2016 6:24 am

Re: View first unread post

Postby gjump » Fri Sep 15, 2017 7:23 pm

Jamartox wrote:Dont you have the down arrow to the left of the thread title?

Down arrow? I don't think so. What's that for?

gjump
Posts: 19
Joined: Thu Nov 24, 2016 6:24 am

Re: ADC positive offset on 0V

Postby gjump » Tue Sep 19, 2017 11:05 pm

Anything? Our client is asking for answers!

Who is online

Users browsing this forum: Google [Bot] and 11 guests