ESP8266 APK 0.97 ,提示设备要升级才能使用。

carrus
Posts: 9
Joined: Mon Apr 27, 2015 10:05 am

ESP8266 APK 0.97 ,提示设备要升级才能使用。

Postby carrus » Fri Jul 24, 2015 6:12 pm

之前使用1.1 .0 SDK IOT DEMO 和 APK 0.92 . 插座可以使用。


最近发现偶尔能使用。 大部分时间不能使用。不知道是不是云端有些变动?


下载.97apk 代码,生成.97apk. 使用.97的 apk 可以激活设备,点击使用时提示,设备要升级才能使用。

下载1.2.0 SDK , 编译IOT DEMO, 烧录到设备里,还是提示设备要升级才能使用。

请帮帮看看是什么原因

xuxiangjun
Posts: 3
Joined: Mon Mar 16, 2015 4:17 pm

Re: ESP8266 APK 0.97 ,提示设备要升级才能使用。

Postby xuxiangjun » Mon Jul 27, 2015 11:06 am

SDK版本兼容现在有点问题

可以修改APK代码来暂时规避版本检查:
在类 com.espressif.iot.model.user.EspUser中的方法:
public EspUpgradeDeviceCompatibility checkDeviceCompatibility(IEspDevice device)
返回值改为: return EspUpgradeDeviceCompatibility.COMPATIBILITY;

Who is online

Users browsing this forum: No registered users and 1 guest