Search found 176 matches

by AgentSmithers
Mon Jul 20, 2020 3:25 pm
Forum: ESP8266 SDK
Topic: Initial Crash on first UART data being sent with screen, but only on first flash.
Replies: 2
Views: 4503

Re: Initial Crash on first UART data being sent with screen, but only on first flash.

Sorry, Been busy with other projects and the whole end of the world thing going on ;) Anyhow, back to work... Yeah, I'm unsure but I don't recall using any interrupts in my project even though its quite extensive now. I do use Deep sleep if you consider that. It almost seems like I'm sending a keyst...
by AgentSmithers
Fri May 08, 2020 9:04 am
Forum: ESP8266 SDK
Topic: Dynamically calling implemented Functions
Replies: 0
Views: 2015

Dynamically calling implemented Functions

typedef struct { char *at_cmdName; int8_t at_cmdLen; void (*at_testCmd)(uint8_t id); void (*at_queryCmd)(uint8_t id); void (*at_setupCmd)(uint8_t id, char *pPara); void (*at_exeCmd)(uint8_t id); }at_funcationType; at_funcationType at_custom_cmd[] = { {"+TEST", 5, NULL, NULL, NULL, myTest_i...
by AgentSmithers
Fri May 08, 2020 4:03 am
Forum: ESP8266 SDK
Topic: espconn_send and Queuing Data
Replies: 0
Views: 1580

espconn_send and Queuing Data

Anyone have a Schmea idea I can follow for queuing data to be sent. It seems NONOS SDK, just buffers and signals the data to be sent when returning back to the system level from userland. What I am looking for is to call the same function twice to queue and send the dataout. One of my ideas was to u...
by AgentSmithers
Thu May 07, 2020 7:45 am
Forum: ESP8266 SDK
Topic: Initial Crash on first UART data being sent with screen, but only on first flash.
Replies: 2
Views: 4503

Initial Crash on first UART data being sent with screen, but only on first flash.

Hi Everyone! Anyone else have this issue after flashing and sending one char of UART data causing the issue below, After I flash my chip and it crashes, after I reset it manually it works fine, no issues at all, but the moment I flash it for the first time it crashes on data input. Anyone know the c...
by AgentSmithers
Tue Mar 31, 2020 12:41 pm
Forum: ESP8266 SDK
Topic: Adding a Library for the MLX90640 and a CPP file
Replies: 0
Views: 3935

Adding a Library for the MLX90640 and a CPP file

Hi Everyone! https://github.com/melexis/mlx90640-library/tree/master/functions https://github.com/linkineo/REDar/blob/master/main/MLX90640_API.c These two links are useful from my google findings. The first one is a library created by the company in CPP but they don't appear to offer it's library in...
by AgentSmithers
Wed Feb 19, 2020 6:51 am
Forum: ESP8266 SDK
Topic: Backing up settings from READ_PERI_REG
Replies: 1
Views: 4593

Re: Backing up settings from READ_PERI_REG

I am starting to work on this issue again. Any pointers would be helpful :)
GPIO_REG_READ may be what I am looking for.
by AgentSmithers
Wed Feb 19, 2020 6:48 am
Forum: ESP8266 SDK
Topic: How to do a secure OTA?
Replies: 4
Views: 4408

Re: How to do a secure OTA?

Thanks for the help Agent! At that point, I am still trying to resolve my issue. I am trying to create a secure connection following the example in Openssl_Client, but so far I have not been able to connect successfully to my google cloud bucket... One of the first issues I am bumping into is that ...
by AgentSmithers
Tue Feb 18, 2020 6:51 am
Forum: ESP8266 SDK
Topic: Upgraded to SDK 2.2.0-3.0.2
Replies: 2
Views: 3906

Re: Upgraded to SDK 2.2.0-3.0.2

Hi everyone!! I am up to 3.0.2 and working!! This is just a theory but a decent one as it seems I may be moving again! I think I may have figured it out.. It appears in SDK 2.2.0 from 2.2.1 seems to have added an RSSI threshhold to the Station_Config strcuture and I think that was filtering out my S...
by AgentSmithers
Fri Feb 14, 2020 1:23 am
Forum: ESP8266 SDK
Topic: Upgraded to SDK 2.2.0-3.0.2
Replies: 2
Views: 3906

Re: Upgraded to SDK 2.2.0-3.0.2

Any pointers or additional information needed (I can fetch) would be greatly appreciated. :)
by AgentSmithers
Sun Feb 09, 2020 5:03 am
Forum: ESP8266 SDK
Topic: Upgraded to SDK 2.2.0-3.0.2
Replies: 2
Views: 3906

Upgraded to SDK 2.2.0-3.0.2

Hi Everyone! I've been on 2.1.0 for quite sometime and decided to take the leap to 3.0.0. After I did I started experiencing intermittent connection issues with my Wifi. Then also creating a snapshot I moved back to 2.1.0 and everything works great again. I also tested 3.0.1 and 3.0.2 and all yield ...

Go to advanced search