Search found 9 matches

by miles
Mon Apr 23, 2018 5:28 pm
Forum: AT+ Commands
Topic: smartconfig成功后调用AT+CIPSTATUS返回值显示未连接?
Replies: 2
Views: 901

Re: smartconfig成功后调用AT+CIPSTATUS返回值显示未连接?

没人回答,自己顶一下,明明smartconfig提示成功,也显示GOTIP了,可是查询AT+CIPSTATUS时显示未连接,究竟是怎么回事?
by miles
Thu Apr 19, 2018 8:29 pm
Forum: AT+ Commands
Topic: smartconfig成功后调用AT+CIPSTATUS返回值显示未连接?
Replies: 2
Views: 901

smartconfig成功后调用AT+CIPSTATUS返回值显示未连接?

采用了随ESP8266_NONOS_SDK-2.2.0发布的官方AT版本,如下打印,麻烦看看是怎么回事?谢谢! AT版本路径:ESP8266_NONOS_SDK-2.2.0\bin\at\1024+1024\user1.2048.new.5.bin [19:51:44 509]AT+CWSTARTSMART [19:51:44 509] [19:51:44 509]OK [19:51:44 509]WIFI DISCONNECT [19:51:44 509]AT+CIPCLOSE=0 [19:51:44 509]0,CLOSED [19:51:44 509] [19:51:44 509]OK ...
by miles
Thu Sep 07, 2017 8:16 pm
Forum: ESP8266 SDK
Topic: ESP8266启动失败,打印乱码,仅重烧系统参数区文件esp_init_data_default.bin后ok,难道参数被改写了?
Replies: 4
Views: 1738

Re: ESP8266启动失败,打印乱码,仅重烧系统参数区文件esp_init_data_default.bin后ok,难道参数被改写了?

虽然我代码支持远程升级,但是写flash操作的位置没有问题,远程升级的功能验证过很多次,且出现问题时,我并没有进行任何远程升级的操作。

但我代码中调用了system_restore()类似操作,代码中还有smartconfig的操作,这些操作应该会影响系统参数区吧。

我现在怀疑这些操作在意外条件下(比如电压不稳,供电不足等)会导致系统参数区内容丢失。系统参数区应该没有备份和校验机制或者该类机制在特定条件下失效了。
by miles
Wed Sep 06, 2017 11:05 am
Forum: ESP8266 SDK
Topic: ESP8266启动失败,打印乱码,仅重烧系统参数区文件esp_init_data_default.bin后ok,难道参数被改写了?
Replies: 4
Views: 1738

Re: ESP8266启动失败,打印乱码,仅重烧系统参数区文件esp_init_data_default.bin后ok,难道参数被改写了?

编译烧录时选的都是16MBit的,但这不是重点,重点是这个问题不是在烧录user1.bin之后出现的,而是运行过程中出现的。
by miles
Thu Aug 31, 2017 11:49 am
Forum: ESP8266 SDK
Topic: ESP8266启动失败,打印乱码,仅重烧系统参数区文件esp_init_data_default.bin后ok,难道参数被改写了?
Replies: 4
Views: 1738

ESP8266启动失败,打印乱码,仅重烧系统参数区文件esp_init_data_default.bin后ok,难道参数被改写了?

ESP8266一开始运行正常,后来突然发现wifi通信异常(此时路由器是好的),ESP8266无法连接上路由器了!!! 于是用户对ESP8266进行按键恢复出厂设置,也就是调用了system_restore()函数,之后就发现ESP8266启动失败,无法响应任何外部事件,包括按键,之后重烧系统参数区文件esp_init_data_default.bin后启动成功,请问系统参数区内容会影响启动打印吗?在什么情况下系统参数区的内容会被改写成无效值?谢谢! 查看串口打印如下: [15:00:00.180] ets Jan 8 2013,rst cause:2, boot mode:(3,6) [15...
by miles
Mon Jun 05, 2017 9:59 am
Forum: ESP8266 SDK
Topic: ESP8266 suddenly boot fail, and never jump to 2nd boot or user code, help!
Replies: 7
Views: 1894

Re: ESP8266 suddenly boot fail, and never jump to 2nd boot or user code, help!

I know it will be ok if reflash all. I am afraid this bug will recur in somehow condition.

I want to analyze the flash to find the cause, and finally resovle this bug or avoid it.

Anyway, thanks a lot!
by miles
Sat Jun 03, 2017 3:09 pm
Forum: ESP8266 SDK
Topic: ESP8266 suddenly boot fail, and never jump to 2nd boot or user code, help!
Replies: 7
Views: 1894

Re: ESP8266 suddenly boot fail, and never jump to 2nd boot or user code, help!

I never put 5V on any module pin. The max voltage is 3.3V. I means the OTA firmware upgrade. I used my own http download code to download firmware, and call spi_flash_write() to upgrade user1.bin to user2.bin or versa. Since i didn't call built-in upgrade function, like system_upgrade_start(), can i...
by miles
Wed May 31, 2017 3:56 pm
Forum: ESP8266 SDK
Topic: ESP8266 suddenly boot fail, and never jump to 2nd boot or user code, help!
Replies: 7
Views: 1894

Re: ESP8266 suddenly boot fail, and never jump to 2nd boot or user code, help!

i am not sure how this start happening. i remembered that i successfully communicated with it when it powered on, that is i sent some request msg and got response msg. But a few minutes later, i found it had been dead, i can't receive any response msg again, and i power off this device, and know it ...
by miles
Thu May 25, 2017 11:35 am
Forum: ESP8266 SDK
Topic: ESP8266 suddenly boot fail, and never jump to 2nd boot or user code, help!
Replies: 7
Views: 1894

ESP8266 suddenly boot fail, and never jump to 2nd boot or user code, help!

i use boot1.2 and use1.bin, and i am sure that i didn't do any upgrade operation, my esp8266 suddenly boot fail, it prints: ets Jan 8 2013,rst cause:2, boot mode:(3,7) ets Jan 8 2013,rst cause:2, boot mode:(3,6) ets Jan 8 2013,rst cause:2, boot mode:(3,6) ets Jan 8 2013,rst cause:2, boot mode:(3,6) ...

Go to advanced search