Search found 10 matches

by AndreiC
Wed Jun 06, 2018 12:16 am
Forum: AT+ Commands
Topic: V 2.2.0 incompatibility
Replies: 5
Views: 1912

Re: V 2.2.0 incompatibility

How do you ignore a message? Well, first you have to accept whatever the module gives you, then recognize the message, then decide to ignore it. You've accepted and recognized the message, what you do with it is reasonably simple, just throw it away. Great, now, update your AT command set and there ...
by AndreiC
Fri May 11, 2018 4:42 am
Forum: AT+ Commands
Topic: V 2.2.0 incompatibility
Replies: 5
Views: 1912

Re: V 2.2.0 incompatibility

Yes, the messages are listed in the appendix. Now, can you give me an idea as to when they are generated and what they mean? My original query was prompted by a whole lot of code falling on its face due to a change in the responses that are generated in V2.2.0. If you take the Arduino stance where y...
by AndreiC
Thu Mar 29, 2018 1:27 am
Forum: AT+ Commands
Topic: V 2.2.0 incompatibility
Replies: 5
Views: 1912

V 2.2.0 incompatibility

Version 2.2.0 introduced the +DIST_STA_IP message being sent by the module. There isn't any documentation for this message, so I don't know when I can expect to receive it.

Will the ESP8266 AT Command Examples document be updated to include the messages introduced in 2.2.0?

Andrei
by AndreiC
Wed Jun 21, 2017 4:27 am
Forum: AT+ Commands
Topic: Quick Data Send Commands
Replies: 3
Views: 1774

Re: Quick Data Send Commands

Beware, I have routinely seen times greater than 500mS between sending a packet and receiving the SEND OK reply.

You may not be able to do what you are expecting.

Andrei
by AndreiC
Wed Jun 21, 2017 4:24 am
Forum: AT+ Commands
Topic: AT+CIPSEND gives error
Replies: 2
Views: 4695

Re: AT+CIPSEND gives error

I didn't look too closely, but my initial observation is that you have a bad protocol error in your code. For instance: 1,CONNECT +IPD,1, 409:GET / HTTP/1.1 Host: 192.168.1.9 Connection: keep-alive Cache-Control: max-age=0 Upgrade-Insecure-Requests: 1 User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; ...
by AndreiC
Fri Jun 09, 2017 4:08 am
Forum: AT+ Commands
Topic: I'm having an issue with TCP RST instead of FIN.
Replies: 6
Views: 3205

Re: I'm having an issue with TCP RST instead of FIN.

I'm just doing some more testing. I fired up Apache on my Mac (it comes installed, you just have to start it), and Chrome (which always would screw up after about 15 seconds) repeatedly loads my page from a local file using file:, localhost using http:, remote mac running chrome, remote iphone runni...
by AndreiC
Tue Jun 06, 2017 6:45 am
Forum: AT+ Commands
Topic: I'm having an issue with TCP RST instead of FIN.
Replies: 6
Views: 3205

Re: I'm having an issue with TCP RST instead of FIN.

Thank you for your help with this matter.

If you need a dump out of Wireshark, let me know.

Getting the serial conversation is a little more difficult, as this is an embedded system connected to the module. The sampling of the serial conversation is currently being done with an oscilloscope.

Andrei
by AndreiC
Fri Jun 02, 2017 12:36 am
Forum: AT+ Commands
Topic: An issue with CIPSEND command
Replies: 1
Views: 1252

Re: An issue with CIPSEND command

You really, really, really have to wait for the "\r\nSEND OK\r\n" reply before continuing. I've seen this come 500mS after the "Recv n bytes" message. During this time the module is busy, and if you try and get it to do something else, it lets you know that it is busy unloading i...
by AndreiC
Mon May 29, 2017 1:22 am
Forum: AT+ Commands
Topic: I'm having an issue with TCP RST instead of FIN.
Replies: 6
Views: 3205

Re: I'm having an issue with TCP RST instead of FIN.

I think one of us is confused. XAMPP is a web server that would run on my PC. My web server is running on an embedded system that uses the ESP8266 as the TCP/IP layer. The embedded system is very small and resource constrained, so I am using the AT command interface, not writing a stack on the 8266....
by AndreiC
Sat May 27, 2017 8:00 am
Forum: AT+ Commands
Topic: I'm having an issue with TCP RST instead of FIN.
Replies: 6
Views: 3205

I'm having an issue with TCP RST instead of FIN.

I've put together a small web server to act as a control and diagnostics panel on a device controlled by an STM32F407 microcontroller. I am using the current latest AT command firmware image (2.1.0). My controller sets up an ESP-01 module as an access point that can take 1 connection with the follow...

Go to advanced search