Search found 13 matches

by alex323qp
Mon Apr 08, 2019 5:53 am
Forum: ESP8266 SDK
Topic: dev 1153 ?
Replies: 8
Views: 2069

Re: dev 1153 ?

For those having this issue, the Espressif team released an update (v3.0.0) back on March that among other things tried to address this problem. Although the number of error messages was reduced significantly, a new error code (dev 1163) seemed to have replaced the previous one with pretty much the ...
by alex323qp
Mon Feb 04, 2019 5:50 pm
Forum: ESP8266 SDK
Topic: dev 1153 ?
Replies: 8
Views: 2069

Re: dev 1153 ?

I uploaded a mcve to the issue tracker a week ago. No one from espressif seems to care about this though. I'm leaving the link here in case anyone wishes to confirm:

https://github.com/espressif/ESP8266_NO ... /issues/90

A.
by alex323qp
Wed Jan 30, 2019 8:36 am
Forum: ESP8266 SDK
Topic: mac 985 ?
Replies: 6
Views: 1393

Re: mac 985 ?

Migrating the code is not an option at this stage, would take months.
by alex323qp
Tue Jan 29, 2019 2:49 pm
Forum: ESP8266 SDK
Topic: mac 985 ?
Replies: 6
Views: 1393

Re: mac 985 ?

Hi AgentSmithers, Thanks for the reply! Yeah, I do have wrappers in the header files that are used as event handlers for the espconn_xxxx callbacks, but my socket class has a private variable (_protocol) that should be unique between instances: // Callback wrapper in the header file (MySocketClass.h...
by alex323qp
Mon Jan 28, 2019 11:11 am
Forum: ESP8266 SDK
Topic: mac 985 ?
Replies: 6
Views: 1393

Re: mac 985 ?

Just an update. This is also happening when only TCP is working, so no UDP related as I originally thought. Having been able to isolate the problem. Very similar to the dev 1153, also still unanswered: https://github.com/espressif/ESP8266_NONOS_SDK/issues/90 https://bbs.espressif.com/viewtopic.php?f...
by alex323qp
Sat Jan 26, 2019 10:36 am
Forum: ESP8266 SDK
Topic: dev 1153 ?
Replies: 8
Views: 2069

Re: dev 1153 ?

Thanks @AgentSmithers appreciate the response! The WTD reset is not the cause of the problem it is just being triggered after the dev 1153 message and the system hangs for a couple of seconds. Feeding the WTD (already tested from the gpio IRQ) just causes the chip to never come back to life since it...
by alex323qp
Fri Jan 25, 2019 3:30 pm
Forum: ESP8266 SDK
Topic: mac 985 ?
Replies: 6
Views: 1393

mac 985 ?

Hi guys, I started to get this message and a WTD reset after implementing a UDP sender. I'm sending less than 100 bytes every 20ms or so. The send is triggered by an external interrupt. After the first espconn_send the IRQ is disabled until sent_callback is called, then the IRQ is re-enabled. Does a...
by alex323qp
Fri Jan 25, 2019 3:22 pm
Forum: ESP8266 SDK
Topic: New FEATURES gathering
Replies: 82
Views: 100913

Re: New FEATURES gathering

Hardware I2C PLEASE (ESP8266)!
by alex323qp
Fri Jan 25, 2019 3:09 pm
Forum: ESP8266 SDK
Topic: dev 1153 ?
Replies: 8
Views: 2069

Re: dev 1153 ?

Hi again, sorry for the VERY late response. Yes, I'm using TCP. I reduced the buffer to 1024 and always waiting for the sent_callback to be called before attempting to send the next package (via task signalling of course). The problem persists. I have a pin interrupt also working which is the one th...
by alex323qp
Fri Jul 06, 2018 1:40 pm
Forum: ESP8266 SDK
Topic: dev 1153 ?
Replies: 8
Views: 2069

dev 1153 ?

Has anyone encountered this error?

It shows up randomly mainly while sending lots of data (the send buffer always full with around 2k bytes), and after a while, I get a wdt reset.

Thanks,

A.

Go to advanced search