Search found 5 matches

by vinicius.vbf
Tue May 16, 2017 11:49 am
Forum: ESP8266 SDK
Topic: Is inet_pton macro missing from RTOS SDK 1.5.0?
Replies: 1
Views: 1158

Is inet_pton macro missing from RTOS SDK 1.5.0?

After upgrading my RTOS SDK from 1.4.0 to 1.5.0, I can't build my project anymore. I keep getting this message: xtensa-lx106-elf-gcc -L/opt/Espressif/ESP8266_RTOS_SDK/lib -Wl,--gc-sections -nostdlib -T/opt/Espressif/ESP8266_RTOS_SDK/ld/eagle.app.v6.new.2048.ld -Wl,--no-check-sections -u call_user_st...
by vinicius.vbf
Wed Apr 20, 2016 5:33 am
Forum: Report Bugs
Topic: DHCP server error when soft-AP client connects with recompiled liblwip.a
Replies: 6
Views: 5496

Re: DHCP server error when soft-AP client connects with recompiled liblwip.a

Thank you all! Just had the exactly same problem. Quick question: why were you recompiling lwip? My reason is because I was having some issues with multicasting, but just found out that the real problem was I was not zeroing the sockaddr_in structure before setting the correct values. Go figure. Som...
by vinicius.vbf
Tue Apr 12, 2016 11:52 am
Forum: ESP8266 SDK
Topic: IOT Platform Sample - espfs alignment error
Replies: 1
Views: 2342

Re: IOT Platform Sample - espfs alignment error

Just found a way to fix it: in your libesphttpd/Makefile file, change the following lines: libwebpages-espfs.a: webpages.espfs $(Q) $(OBJCOPY) -I binary -O elf32-xtensa-le -B xtensa --rename-section .data=.irom0.literal \ --redefine-sym _binary_webpages_espfs_start=webpages_espfs_start \ --redefine-...
by vinicius.vbf
Wed Mar 02, 2016 10:29 am
Forum: ESP8266 SDK
Topic: What is NONOS?
Replies: 1
Views: 3431

Re: What is NONOS?

I believe that it should be read as NON-OS, which is different from the RTOS (Real Time Operating System) SDK version. Although, in the RTOS documentation we can read this: APIs of "ESP8266_RTOS_SDK" are same as "ESP8266_NONOS_SDK" This is what I get from it: the RTOS SDK is base...
by vinicius.vbf
Wed Mar 02, 2016 10:15 am
Forum: ESP8266 SDK
Topic: IOT Platform Sample - espfs alignment error
Replies: 1
Views: 2342

IOT Platform Sample - espfs alignment error

Hello! I'm trying to make the IOT Platform Sample (Plug) work, but I'm getting an error regarding the filesystem alignment. When I try to access the page /index.html, I get the error 404 not found. In the serial log, the following error is shown: should call espfsint first The call is made in user_i...

Go to advanced search