Search found 32 matches

by Pato
Fri Jun 22, 2018 5:38 pm
Forum: ESP8266 SDK
Topic: OTA upgrade never finishes
Replies: 9
Views: 3050

Re: OTA upgrade never finishes

Hey ! I merely replaced the code in the tcp_recv_cb() by my custom code to use the SPI flash function from Espressif instead of the one of rboot (https://github.com/raburton/rboot-sample). It still need to be cleaned up as it was brute test-and-dev, but the basis is here: typedef struct { uint8 rom_...
by Pato
Sun Jun 17, 2018 6:17 pm
Forum: ESP8266 SDK
Topic: OTA upgrade never finishes
Replies: 9
Views: 3050

Re: OTA upgrade never finishes

Hey ! As I could not find out why the OTA library does not work with my environment, I ended up rewritting my own OTA upgrade library, according to what AgentSmither said and like many other pieces of codes on the net do: - Send a HTTP GET request to my local server to download the file - Use system...
by Pato
Mon Jun 11, 2018 6:50 pm
Forum: ESP8266 SDK
Topic: [solved] Network found by wifi_station_scan() but "no Network found, reconnect after 1s"
Replies: 3
Views: 1888

Re: Network found by wifi_station_scan() but "no Network found, reconnect after 1s"

Ho dude, Indeed it was about uninitialized fields in the struct station_config ! However set the bssid_set field = 0 alone (to not connect only if the BSSID matches, cf. doc) was not sufficient, two other fields must be set: struct station_config stationConfig; os_strcpy(stationConfig.ssid, ssid); o...
by Pato
Fri Jun 08, 2018 10:36 pm
Forum: ESP8266 SDK
Topic: [solved] Network found by wifi_station_scan() but "no Network found, reconnect after 1s"
Replies: 3
Views: 1888

[solved] Network found by wifi_station_scan() but "no Network found, reconnect after 1s"

Hi dear folks, I ask for explaination for the following behavior of the ESP8266 in station mode, with the NONOS_SDK_2.2.0. When connecting to the the wifi network called MyNetwork, and listing the visible APs, I got the following output from the SDK (I print the list of AP scanned and the reason of ...
by Pato
Wed Jun 06, 2018 7:59 pm
Forum: ESP8266 SDK
Topic: what files to flash for NON OS SDK
Replies: 3
Views: 1622

Re: what files to flash for NON OS SDK

Hey, The two files "eagle.flash.bin" and "eagle.irom0text.bin" are the final outputs from the compiler. E.g. if you use the ./gen_misc script to build your app (or one of the example), at step 2 the script will ask you if you want to generate these two files (for non-FOTA) or use...
by Pato
Wed Jun 06, 2018 6:06 pm
Forum: ESP8266 SDK
Topic: OTA upgrade never finishes
Replies: 9
Views: 3050

Re: OTA upgrade never finishes

Hey AgentSmithers, Thanks for your interest ! I post below the very same code I use (I made it minimalistic so that it is easier to post). I simply replaced the user_main.c of the NONOS_SDK_2.2.0/examples/IoTDemo project by this one, and I build it with ./gen_misc.sh without any errors, using the pr...
by Pato
Tue Jun 05, 2018 10:42 pm
Forum: ESP8266 SDK
Topic: OTA upgrade never finishes
Replies: 9
Views: 3050

OTA upgrade never finishes

Hi folks, I'm trying to implement OTA upgrade with the NON-OS SDK 2.2.0 on the ESP8266, upgrading from a local server. My application finds the file (I can see in the server log that the HEAD and GET request succeeded) and the ESP seems to erase some sectors. However, after all sector have been eras...
by Pato
Tue May 15, 2018 11:59 pm
Forum: ESP8266 SDK
Topic: about using math
Replies: 6
Views: 1833

Re: about using math

It may help, I was able to link against the math lib after some tweaking:

https://bbs.espressif.com/viewtopic.php?f=7&t=9432
by Pato
Fri Apr 06, 2018 10:10 pm
Forum: ESP8266 SDK
Topic: Disable echo on UART0
Replies: 2
Views: 1443

Disable echo on UART0

Hello, On the ESP8266-12 with the NONOS-SDK-2.2.0, every char I send on the RX pin of the UART0 is reprinted/echoed on the TX pin. How to disable this annoying echo ? Thx ! (I suspected the "loopback" feature to be enabled by default, but clearing bit 14 of UART_CONF0(0) didn't help: SET_P...
by Pato
Fri Apr 06, 2018 10:02 pm
Forum: ESP8266 SDK
Topic: Linking against the math library
Replies: 1
Views: 958

Re: Linking against the math library

It appeared that I need to look recursively for the libraries in the linking command, ie to use "Wl" flag: [b]-Wl,[/b]--start-group -lmain -lnet80211 -lwpa -llwip -lpp -lphy -lhal -lc -lgcc -ldriver [b]-lm[/b] [b]-Wl,--end-group[/b] Moreover, the fmod() and fmof() are relying by default on...

Go to advanced search