Search found 467 matches

by pratik
Tue Sep 05, 2017 8:23 pm
Forum: AT+ Commands
Topic: Wifi functions not working
Replies: 3
Views: 2463

Re: Wifi functions not working

The chip is usually okay, but the antenna section is not well-matched. Usually the case with MANY ESP-01 modules.
by pratik
Tue Sep 05, 2017 8:22 pm
Forum: ESP8266 SDK
Topic: Unexpected additional sectors erased using Flash Download Tool
Replies: 2
Views: 1768

Re: Unexpected additional sectors erased using Flash Download Tool

The issue has been forwarded to the developers of the Flash Download Tool. I will let you know if I get any new info on this. Thanks for writing about it!
by pratik
Tue Sep 05, 2017 8:21 pm
Forum: AT+ Commands
Topic: UART character delay?
Replies: 1
Views: 1400

Re: UART character delay?

No, the AT command set does not allow that setting. The best you can do is lower the baud rate to 9600 maybe. If your uC is running at <8MHz and has no UART FIFO, then you are bound to miss packets! This is because the ESP8266 UART has DMA + FIFO, and it transfers bytes out with almost zero loading ...
by pratik
Tue Sep 05, 2017 4:39 pm
Forum: AT+ Commands
Topic: +IPD command lacking LF ??
Replies: 1
Views: 1511

Re: +IPD command lacking LF ??

Can you let me know which firmware version you are using?
You can find out using AT+GMR
by pratik
Tue Sep 05, 2017 4:37 pm
Forum: AT+ Commands
Topic: Hardware flow control UART
Replies: 6
Views: 4683

Re: Hardware flow control UART

The UART baud rate configuration AT command can be used to enable flow control. Please check the AT command documentation for your version of the firmware.
As for the GPIOs, when flow control is enabled:
GPIO12 = U0DTR
GPIO13 = U0CTS
GPIO14 = U0DSR
GPIO15 = U0RTS
by pratik
Tue Sep 05, 2017 4:34 pm
Forum: AT+ Commands
Topic: More softAPs at once
Replies: 6
Views: 3223

Re: More softAPs at once

I'm not sure I understand your network configuration. You want 1 ESP to act as multiple softAPs?
Or do you want to have 2 softAP+STA mode ESPs connected to each other?
by pratik
Tue Sep 05, 2017 4:31 pm
Forum: AT+ Commands
Topic: Initial definition saved in Flash
Replies: 3
Views: 2136

Re: Initial definition saved in Flash

This is not possible right away using a standard method. But there is a way, which will take some experimentation. Everything stored in the flash by the firmware is in the last 16kB of the memory. You can see the flash map from Getting Started Guide. So what you can try is, send the commands you wan...
by pratik
Fri Sep 01, 2017 9:20 pm
Forum: ESP8266 SDK
Topic: PainlessMesh ESP8266 mesh library for Arduino IDE
Replies: 11
Views: 20107

Re: PainlessMesh ESP8266 mesh library for Arduino IDE

I think there is a header file missing. You should raise an issue with the developer of PainlessMesh so they can update the code if required.
by pratik
Fri Sep 01, 2017 9:10 pm
Forum: AT+ Commands
Topic: Wifi functions not working
Replies: 3
Views: 2463

Re: Wifi functions not working

Can you set the ESP up as an access point? And is this happening with all modules?
The CWLAP command does fail sometimes, there have been previous bug reports of this before.
by pratik
Fri Sep 01, 2017 9:05 pm
Forum: ESP8266 SDK
Topic: Flash fails on ESP8266-01 based on SDK2.0
Replies: 5
Views: 1988

Re: Flash fails on ESP8266-01 based on SDK2.0

The "garbage" you get printed is legible at 74880 baud rate.
Please post the terminal log here so I can see what is happening.

Go to advanced search