Search found 467 matches

by pratik
Sun Jul 03, 2016 3:10 pm
Forum: ESP8266 SDK
Topic: delete an station record
Replies: 3
Views: 1960

Re: delete an station record

Hello SpenZerX, You may set the number in user_init . It seems to work just fine. The default should be 5, but it is a good idea to make sure it actually is 5, since it is stored in flash and depends on the configuration data stored in there. A previous session might have changed that! wifi_station_...
by pratik
Sun Jul 03, 2016 1:32 pm
Forum: ESP8266 SDK
Topic: [SOLVED] How can i login to a WiFi network?
Replies: 5
Views: 3443

Re: How can i login to a WiFi network?

Hello Stational, Did you leave the SSID and PASSWORD strings empty? For which line of code are you getting this error? In the following code, you need to define SSID and PASSWORD strings, for example, SSID can be "home_router" and PASSWORD is "admin". char ssid[32] = SSID; char p...
by pratik
Fri Jul 01, 2016 11:13 pm
Forum: AT+ Commands
Topic: Wifi scan procedure
Replies: 4
Views: 2465

Re: Wifi scan procedure

Hello Jan, I was able to reproduce this behavior using the AT firmware version that you specified (SDK 1.5). It does not always return the networks available when the mode is changed. And CWMODE = 1 and 3 are both prone to the same issue. Trying to join an AP (that does not exist) seems to clear the...
by pratik
Fri Jul 01, 2016 2:53 pm
Forum: ESP8266 HDK
Topic: ESP8266-07 UART Rx issues
Replies: 1
Views: 2636

Re: ESP8266-07 UART Rx issues

Hello asmoulder3195, According to what you said, it seems that the problem is observed only with ESP-07 modules. Note that the red LED is probably directly connected to Vcc and ground with a resistor so it will turn on regardless of the power supply conditions. One thing that I notice is that your c...
by pratik
Thu Jun 30, 2016 9:47 pm
Forum: AT+ Commands
Topic: Solid blue light, Esp not working in normal mode
Replies: 5
Views: 13537

Re: Solid blue light, Esp not working in normal mode

Hello Gaspar, Which module are your using? If it is the ESP-12 or similar and you have a solid blue light... it is usually a power supply or improper startup issue. The ESP8266 may heat up and draw high current as well. If any of this happens, please try these two options first: 1. Add a 10 or 22 or...
by pratik
Thu Jun 30, 2016 9:12 pm
Forum: General Q&A
Topic: reboot esp based device due to excetion reset(reset reason 2)
Replies: 3
Views: 2489

Re: reboot esp based device due to excetion reset(reset reason 2)

Hello Valmik, You mentioned reset cause 2 and said that you get "exception reset". Did you mean that you are getting an exception and after that a reset? You may find reset cause 2 if the chip is being reset by a low voltage on the reset pin. This is usually a circuit design issue. Please ...
by pratik
Wed Jun 29, 2016 10:38 pm
Forum: ESP8266 SDK
Topic: [SOLVED] ESP8266_NONOS_SDK_V1.5.4_16_05_20 compiler problem?
Replies: 2
Views: 1988

Re: ESP8266_NONOS_SDK_V1.5.4_16_05_20 compiler problem?

Hello Lou0908, You will need to modify the makefile to make the compiler include the file. For example, you can add INCLUDES += -I <relative_path> Where <relative_path> is the relative path of uart.h and the makefile you modify should be the one in the directory of the file that is calling the uart ...

Go to advanced search