SDK 0.9.5 + new AT 0.21 doesn't work???

rgregor
Posts: 9
Joined: Fri Feb 06, 2015 6:45 am

SDK 0.9.5 + new AT 0.21 doesn't work???

Postby rgregor » Mon Feb 09, 2015 5:03 pm

Hello,
I have downloaded SDK 0.9.5. I am able to compile it and everything is fine. However, I wanted to check the new AT commands 0.21. So based on the SDK, I went to esp_iot_sdk_v0.9.5\bin\at\ directory and did exactly, what is in the readme:

boot_v1.2.bin 0x00000
user1.512.new.bin 0x01000
blank.bin 0x3e000 & 0x7e000

But after that, when I start the module, I don't have anything going out even any answer to AT. Only when power on, I have this:

Œ lì b|Ž‚ì’r’bl bŒònnžlnnœâì bpìŽlrlrl‚rò’nàbânbp

What I am doing wrong. Should I also load the user2.512.new.bin ? At which address?

After loading of the old AT firmware, everything is fine and working, so there is no issue with the connection, hw or something like that.

ESP_Faye
Posts: 1646
Joined: Mon Oct 27, 2014 11:08 am

Re: SDK 0.9.5 + new AT 0.21 doesn't work???

Postby ESP_Faye » Mon Feb 09, 2015 5:59 pm

Hi,

Thanks for your interest in ESP8266 !

Our AT bin can works fine , please check:
baudrate is 115200
AT commands end with CR LF

download as picture below
download_tool.png
download_tool.png (44.15 KiB) Viewed 10758 times

rgregor
Posts: 9
Joined: Fri Feb 06, 2015 6:45 am

Re: SDK 0.9.5 + new AT 0.21 doesn't work???

Postby rgregor » Tue Feb 10, 2015 6:09 am

Hello, I see. Ok, thanks a lot for the quick reply. It is working now. The problem probably was, that I was using that simple flasher tool and I updated in the order boot, user1, blank, blank. Seems this doesn't work. But with that esp flasher tool it is now working...

Thx!

milesstone
Posts: 140
Joined: Mon Apr 26, 2021 4:50 pm

Re: SDK 0.9.5 + new AT 0.21 doesn't work???

Postby milesstone » Tue Jun 21, 2022 12:40 am

I am thankful to you and I also would like to share it with my friends via this OG WhatsApp who has this issue.

Who is online

Users browsing this forum: No registered users and 2 guests