Page 1 of 1

Server Closes connection AFter every AT+CIPSEND command.

Posted: Sat Jun 02, 2018 2:47 pm
by harry123
Hi,

I have a ESP-12f module that I am going to use to download a few hundred small files from our comapnies server. Unfortunately every time I download a single file, the connection is closed and I have to re-establish a new TCP connection. I have tried this on multiple servers and always get the same result. For example, when I issue these commands on Google:

AT+CIPSTART="TCP","google.com",80
AT+CIPSEND=29
GET http://www.google.com

Google sends me the webpage data that finishes with: "CLOSE" . And then I cannot issue any new CIPSEND commands unless I re-establish the connection using AT+CIPSTART="TCP","google.com",80 .

Since a TCP connection takes about 1 second to establish and I need to repeat this hundreds of times, I lose a lot of time when downloading multiple files. I also used the "TCP keep alive" parameter from the datasheet that is explained like this:

[<TCP keep alive>] optional, detection time interval when TCP is kept alive,
this function is closed by default.
0 : disable TCP keep-alive
1 ~ 7200 : detection time interval, unit: second

I used 1 and 1000 like this:

AT+CIPSTART="TCP","google.com",80,1

AT+CIPSTART="TCP","google.com",80,1000

But none of the above seem to be working and the connection is still closed immediately after one file is downloaded.

Is there any way to keep the connection alive until I manually close it myself?

Re: Server Closes connection AFter every AT+CIPSEND command.

Posted: Tue Jun 05, 2018 2:24 pm
by Her Majesty
The port 80 is usually for short connection.
Maybe you should ask your company's server engineer, how to make a long connection with your company server.
Hope to be helpful.

Server Closes connection AFter every ATCIPSEND command

Posted: Mon Sep 03, 2018 6:29 am
by andreysnug
No matter how big my files are, after upload of just one the connection always terminates. It propably is an issue of the right settings in ftpcafe, since on the PC with Filezilla I do not have any problems. What could be the problem?