How increase data transmission speed to server using AT+CIPSEND command?

vishal.borle
Posts: 5
Joined: Fri Dec 29, 2017 6:29 pm

How increase data transmission speed to server using AT+CIPSEND command?

Postby vishal.borle » Fri Feb 01, 2019 10:01 pm

Hi to all,
We are using ESP12E version and this interface with external host MCU via UART communication. We are able to send data to server using AT command, the following parameter and data size that we have used in our application.
1. Sending data size: 74Kbytes
2. AT command used: AT+CIPSTART using TCP, AT+CIPSEND, AT+CIPCLOSE.
3. External host MCU UART parameter setting:
Baudrate: 115200
flow control: diabled
parity: 0

For our critical problem is:
We are able to send this all data to server but it taking approx 1 minute for transmitting data to server. This problem is critical for us because our product is battery operated device using 2*1.5V AA size. So battery life is important feature in our application.
Questions:
1. Why this taking too much time for transmission ?
2. Is any other parameter that i need to set in my code, Because we are communicating to ESP12E using AT command through UART?
3. What is the maximum speed for transmission data to server using AT cmd? Is any limitation?
4. Will you please suggest any best solution for increasing transmission speed to reduced this time improve battery life?

Looking forward your response..!!

Thanks....
vsborle

vishal.borle
Posts: 5
Joined: Fri Dec 29, 2017 6:29 pm

Re: How increase data transmission speed to server using AT+CIPSEND command?

Postby vishal.borle » Tue Mar 05, 2019 3:21 pm

Looking forward your reply/response?
Please suggest any other method or solution.
vsborle

Her Majesty
Posts: 373
Joined: Mon Oct 27, 2014 11:09 am

Re: How increase data transmission speed to server using AT+CIPSEND command?

Postby Her Majesty » Wed Mar 06, 2019 2:11 pm

How about using the UART-WiFi passthrough mode instead?

vishal.borle
Posts: 5
Joined: Fri Dec 29, 2017 6:29 pm

Re: How increase data transmission speed to server using AT+CIPSEND command?

Postby vishal.borle » Mon Mar 18, 2019 10:23 pm

I have used another method like UART-passthrough mode but still problem. The transmission speed slight improved but not as expected. The speed only has improved 10% which is very less. Will you please tell me Is any having other configuration at server side that i should nee to change.

We are still finding the solution for this problem, and until not get any help form here as well as from other espressif forum also.
I am waiting more for the answer of my question but still not able to give me solution ans well as suggestion for what should i do now?

Can anyone tell what is the maximum speed of ESP12E data transfer to server using AT command.
Is this module that i am using not able to transmit data fast, Should i need to change this module?
vsborle

Who is online

Users browsing this forum: No registered users and 1 guest