Page 1 of 1

ESP8266 does not respond back to Arduino

Posted: Tue Feb 21, 2017 10:07 pm
by jclmdt
I'm new to this wifi chip. My problem is that I am unable to get a respond from esp8266 when i connect it with arduino mega.

Like many tutorials online, I followed the instructions but is still unable to get any respond.

I connect the mega GND to esp8266 GND and mega 3.3V is connected to vcc and ch_pd of esp8266. Tried using an external supply to power the esp8266 but yields the same result (no response from esp8266). The TX of mega connects to RX of esp8266 (via 10k and 20k voltage divider) and RX of mega connects to TX of esp8266.

I also had a simple code uploaded to the arduino, where any command receive from the serial monitor is forwarded to the serial connected to esp8266 (mega has 4 hardware serial ports). However, even a simple 'AT' command yields no response from the wifi chip.

Please help. I have searched many tutorials and forum online but none of it solve my problem.

Thank you in advance.

Re: ESP8266 does not respond back to Arduino

Posted: Wed Mar 01, 2017 2:20 pm
by pratik
You will probably need to re-flash the AT command firmware to the ESP8266 module you are using. You may follow some tutorial on that, there are plenty around.
By the way, using a resistor divider to divide the UART levels is very unreliable as a divider can step down the voltage levels but cannot step it up. So please try a proper terminal interface with true 3V3 Rx/Tx and see if things work.