Page 1 of 1

ESP-WROOM-02D Unable to respond to AT commands

Posted: Sat Oct 19, 2019 12:21 am
by travjav
Hello everyone,

I need some help determining why ESP-WROOM-02D does not respond back to me other than when i boot it up and click the reset button; in which case I receive a "ready".

I have two different modules of these and they both respond the same way on different computers using different apps ( I used the Arduino serial ) and another application for Linux and always get the same result, which is no response. I have tried different variations i.e new line and return with no luck. I also am using the correct baud rate specified by the manufacturer which is 115200 along with other baud rates higher or lower but am unable to get anything. I also have tried hooking this up to my ARM device and sending AT commands with no luck, i'm really unsure how to proceed at this point and is becoming the main blocker in my project and we're dependent on the success of it's connectivity. Any help is appreciated, thank you.

manufacturers site:

Re: ESP-WROOM-02D Unable to respond to AT commands

Posted: Mon Oct 21, 2019 10:47 am
by Her Mary
AT command ends with a new line (CR LF). But some serial tool do not have "new line mode", maybe you can have a try with the secureCRT, it support "new line mode" (CR LF).

Re: ESP-WROOM-02D Unable to respond to AT commands

Posted: Sun Oct 27, 2019 11:18 am
by travjav
Hey thanks for responding, I got this it has been solved. For some reason my one line was not making proper contact I had to clean the pin and after I was able to get it going using AT+CWMODE= X