SNTP not working in ESP8266

Posts: 5
Joined: Sat Aug 12, 2017 9:30 pm

SNTP not working in ESP8266

Postby exerion » Fri Aug 18, 2017 6:18 pm


I'm always getting the same result with the CIPSNTPTIME? command: "+CIPSNTPTIME:Thu Jan 01 00:00:00 1970".
It's using the default servers, and I tested them outside the ESP just to check conectivity. Servers are active and reachable.
ESP is correctly connected to Wifi, STA mode, etc. I have tried different steps, configurations, servers, etc. It's always returning the same time (epoch).

Any suggestion?

ESP info:
AT version: 5 2017 16:10:59)
SDK version:2.1.0(116b762)

Posts: 1640
Joined: Mon Oct 27, 2014 11:08 am

Re: SNTP not working in ESP8266

Postby ESP_Faye » Wed Aug 23, 2017 5:01 pm


You need to set the time zone first.

Code: Select all

AT+CIPSNTPCFG=1,8 //set time zone

If your problem is still unsolved, please feel free to let me know.
Sorry for the inconvenience.

Who is online

Users browsing this forum: No registered users and 3 guests