Page 1 of 1

Esp8266 ESP-01 module - not listing APs - no wifi in general

Posted: Sun Jan 22, 2017 5:03 am
by neko12
Hello everyone!

I have bought ESP8266 ESP-01 module, the black one, with 1MB flash, with "AI - cloud inside" text on board.

I tried with AT commands on Putty with all possible baud rates with no luck. Then I set the baud rate to 74880 and reset the device, which gave me something like "main_ets.c" as response. I googled a little and read somewhere that module is blank.

First, I downloaded the latest version of SDK "ESP8266_NONOS_SDK_V2.0.0_16_07_19" and flasher and successfully flashed the module. Again tried some AT commands with Putty and it worked. AT commands work, but WIFI is not working. AT+CWLAP not listing APs, just returns OK (I tried with two different APs). I tried with station and AP+station mode, nothing. When I set it to AP mode, I do not see its wifi network from my phone and notebook.

I have downloaded other versions of SDK and flashers and some AI thinker bins. Flashed successfully. AT commands work, but no APs listed, no WIFI, nothing.

Is it possible that only wifi part of the module is not working? Somobody with an idea?

P.S. I tried with two different power supplies and with both of them the voltage drops from 3.3v to 2,8v when I connect the module.

Re: Esp8266 ESP-01 module - not listing APs - no wifi in general

Posted: Tue Jan 24, 2017 4:23 pm
by ESP_Xutao
this is my log information

Code: Select all







if you want to user AT command,you can consult our AT example Doc. ... les_en.pdf

Re: Esp8266 ESP-01 module - not listing APs - no wifi in general

Posted: Tue Jan 24, 2017 7:30 pm
by neko12
ESP_Xutao, thank you for response.

Tried that. Not working.

Here is the log:

Code: Select all





Re: Esp8266 ESP-01 module - not listing APs - no wifi in general

Posted: Mon Mar 19, 2018 11:08 pm
by MIKE-8266
I have the same problem. My ESP8266-01 (1MB) can
respond properly to AT+CWLAP when it has v0.9.2.2 AT Firmware.bin firmware on it.
I've flashed it with SDK's 2.2, 2,1 and 2.0 (Using Flashdownloader 2,3) yet when I do AT+CWLAP
it just seems to 'think' for about 10 seconds then prints OK. Other AT commands seem to respond fine.
I've tried AT+CWMODE 1 and 3 but not success.
The Baud rate after flashing using (SDK 3.3, 2.1 and 2.0) operates at 74880, i.e. allows AT input/output, something I have
never seem before. Usually after flashing, 9600 or 115200 were the BAUD rates for proper AT command
communications and powering on with the 74880 BAUD simply just used to give a "report" and no scope to interact with AT commands.
I thought maybe the Module had to be set to Baud of 115200, so I did AT+CIOBAUD=115200 (which had worked
in the past with other ESP-01, 512KB and 1MB modules) but now trying to change the BAUD didn't work,
so I tried the 'updated' AT+UART=115200,8,1,0,3
but after power cycling with Serial Coms Terminal (Arduino Serial Monitor) at 115200 Baud, I couldn't enter any AT commands.
This is the first time this has happened to me. I can't figure out a reason.
In summary: How to get data back from an AT+CWLAP command and how to change the Baud rate?
(I've read the documentation but I can't find out what I'm doing wrong)
Thank you.