[Resolved]station连接加密的AP或者路由器时,连接不上,系统返回STATION_CONNECT_FAIL

superhamstar
Posts: 17
Joined: Tue Mar 24, 2015 1:46 pm

Re: station连接加密的AP或者路由器时,连接不上,系统返回STATION_CONNECT_FAIL

Postby superhamstar » Fri Aug 14, 2015 8:43 am

ssid: ham_AP
password: cmosandttl082823


ssid: JCG-90D3AC
password: 757407037A


ssid: WIFI_TEST
password: cmosandttl
Attachments
esp_sdk_v1.3.zip
(4.88 MiB) Downloaded 223 times

ESP_Faye
Posts: 1641
Joined: Mon Oct 27, 2014 11:08 am

Re: station连接加密的AP或者路由器时,连接不上,系统返回STATION_CONNECT_FAIL

Postby ESP_Faye » Fri Aug 14, 2015 11:04 am

您好,

非常抱歉,您提供的软件包,我这边始终提示内含病毒,无法使用。

附件为根据您提供的 AP 信息,编译的 bin 文件,请测试使用。
eagle.flash.bin 烧录到 0x00000
eagle.irom0text.bin 烧录到 0x40000
blank.bin 烧录到flash 倒数第二个 sector,例如,选择 flash size 为 512KB,则烧录到 0x7E000

请注意 烧录时确认选择的是对应的 bin 文件。
Attachments
bin_WIFI_TEST.zip
(153.12 KiB) Downloaded 345 times
bin_JCG-90D3AC.zip
(153.12 KiB) Downloaded 418 times
bin_ham_AP.zip
(153.12 KiB) Downloaded 412 times

superhamstar
Posts: 17
Joined: Tue Mar 24, 2015 1:46 pm

Re: station连接加密的AP或者路由器时,连接不上,系统返回STATION_CONNECT_FAIL

Postby superhamstar » Fri Aug 14, 2015 3:29 pm

使用您编译的bin文件能够正常连接加密的路由器。这是什么原因,是不是我的编译器版本不对?

ESP_Faye
Posts: 1641
Joined: Mon Oct 27, 2014 11:08 am

Re: station连接加密的AP或者路由器时,连接不上,系统返回STATION_CONNECT_FAIL

Postby ESP_Faye » Fri Aug 14, 2015 4:10 pm

STATION_CONNECTING
reconnect
scandone
f 0, scandone
reconnect
f -240, scandone
reconnect
f 0, scandone
reconnect
f 0,
STATION_CONNECT_FAIL

您好,

我向内部工程师确认了,从您提供的log 看来,您并未更新到 sdk_v1.3.0,仍然使用的是旧版本的 SDK。

在 sdk_v1.3.0 中,我们增加了一些 log,您运行我提供的 bin 文件时,应该能看到。而您提供的这段 log 并未打印出 sdk_v1.3.0 新增的信息。

麻烦更新到 esp_iot_sdk_v1.3.0 测试。

superhamstar
Posts: 17
Joined: Tue Mar 24, 2015 1:46 pm

Re: station连接加密的AP或者路由器时,连接不上,系统返回STATION_CONNECT_FAIL

Postby superhamstar » Sat Aug 15, 2015 11:14 am

问题解决了,谢谢!

Who is online

Users browsing this forum: No registered users and 1 guest