Page 1 of 1

esphttpd OTA

Posted: Fri Feb 02, 2018 3:09 pm
by htwtsang
Hey

I am currently developing using the esphttpd library and I want to get the OTA working but I have some problems.I'm playing around with the demo and am struggling to get the code to compile. It seems to be getting stuck on the following line of code:

Code: Select all

$(3): $(1)
   $$(vecho) APPGEN $$@
   $$(Q) $$(OBJCOPY) --only-section .text -O binary $1 build/eagle.app.v6.text.bin
   $$(Q) $$(OBJCOPY) --only-section .data -O binary $1 build/eagle.app.v6.data.bin
   $$(Q) $$(OBJCOPY) --only-section .rodata -O binary $1 build/eagle.app.v6.rodata.bin
   $$(Q) $$(OBJCOPY) --only-section .irom0.text -O binary $1 build/eagle.app.v6.irom0text.bin
   $$(Q) cd build; COMPILE=gcc PATH=$$(XTENSA_TOOLS_ROOT):$$(PATH) python $$(APPGEN) $(1:build/%=%) 2 $$(ESP_FLASH_MODE) $$(ESP_FLASH_FREQ_DIV) $$(ESP_FLASH_SIZE_IX) $(4)
#   $$(Q)  $$(APPGEN) $$(TARGET_OUT_USR1) 2 $$(ESP_FLASH_MODE) $$(ESP_FLASH_FREQ_DIV) $$(ESP_FLASH_SIZE_IX) $(4)
   $$(Q) rm -f eagle.app.v6.*.bin
   $$(Q) mv build/eagle.app.flash.bin $$@
   @echo "** user1.bin uses $$$$(stat -c '%s' $$@) bytes of" $$(ESP_FLASH_MAX) "available"
endef


error message:

Code: Select all

wifi/wifi.tpl (55%, heatshrink)
make[1]: Leaving directory `/c/Espressif/examples/ESP8266/esphttpd-master/libesphttpd'
AR build/httpd_app.a
APPGEN firmware/httpd.user1.bin
/usr/bin/sh: -c: line 0: syntax error near unexpected token `('
/usr/bin/sh: -c: line 0: `cd build; COMPILE=gcc PATH=C:/Espressif/xtensa-lx106-elf/bin:C:\MinGW\bin;C:\MinGW\msys\1.0\bin;C:\MinGW\msys\1.0\usr\bin;C:/Program Files/Java/jre1.8.0_144/bin/client;C:/Program Files/Java/jre1.8.0_144/bin;C:/Program Files/Java/jre1.8.0_144/lib/i386;C:\ProgramData\Oracle\Java\javapath;C:\Program Files\Intel\iCLS Client\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\OpenCL SDK\2.0\bin\x86;C:\Program Files\nodejs\;C:\Program Files\TortoiseSVN\bin;C:\Python27;C:\MinGW\bin;\opt\xtensa-lx106-elf\bin;\bin;C:\Users\pdd-hugo.tsang\AppData\Roaming\npm;C:\SysGCC\esp8266\bin;C:\eclipse python c:/Espressif/utils/ESP8266/gen_appbin.exe httpd.user1.out 2 0 0 5 1'
Makefile.ota:51: recipe for target 'firmware/httpd.user1.bin' failed
mingw32-make.exe: *** [firmware/httpd.user1.bin] Error 258


I tried to switch the python $$(APPGEN) to just $$(APPGEN) since APPGEN was just defined by $(SDK_TOOLS)/gen_appbin.exe but that didnt work, it seems like a path error but I'm not too knowledable in makefile to figure out what exactly is wrong with it.

Any suggestions would be appreciated