ESP-01 AP mode resets in certain (geographical) locations

bosco.dsouza.82
Posts: 1
Joined: Mon May 02, 2016 1:25 pm

ESP-01 AP mode resets in certain (geographical) locations

Postby bosco.dsouza.82 » Wed Oct 05, 2016 9:32 pm

We are using ESP-01 (in AP mode). However we are facing a problem during our field tests.
The ESP-01 resets in certain (geographical) locations. For the sake of our internal discussions, we refer to these locations as deadzones. (Maybe there's a better technical name for them). The size of the deadzones is around a few hundred feet.
ESP-01 works fine (and as expected) when we are out of the deadzones.


Firmware details
=============
Stock (NON-OS) Firmware
SDK Version: 1.5.2
AT Version: 0.60

So far, we have been working with the AT command set.


Other important details

===================
1. In the dead zone, ESP-01 resets only in AP mode and not in STATION mode.
2. Tried powering the ESP-01 through 3 different methods, to rule out power-related issues. Resets in all 3 methods, while in the deadzones.
3. iOS or Android phone hotspots work fine in the deadzones.
4. Some deadzones only affect ESP-01 AP in channel 1, whereas others affect in channel 6, whereas some others affect it in all channels.



While in the dead zone, the output on UART0 is as follows...


ets Jan 8 2013,rst cause:4, boot mode:(3,6)

wdt reset
load 0x40100000, len 1856, room 16
tail 0
chksum 0x63
load 0x3ffe8000, len 776, room 8
tail 0
chksum 0x02
load 0x3ffe8310, len 552, room 8
tail 0
chksum 0x79
csum 0x79

2nd boot version : 1.5
SPI Speed : 40MHz
SPI Mode : DIO
SPI Flash Size & Map: 8Mbit(512KB+512KB)
jump to run user1 @ 1000

r[18][02]Ž[1B]ùú
Ai-Thinker Technology Co. Ltd.

ready



Questions
=========
1. Is this due to (faulty) power?
2. Is this due to electromagnetic/RF reasons?
3. Is this due to a firmware bug, perhaps due to reception of some 802.11 packets in AP mode?
4. Any further data that we need to collect to narrow down the cause of the problem?



Please advise.

Who is online

Users browsing this forum: No registered users and 1 guest