UART BAUDRATE

piotrva
Posts: 9
Joined: Mon Jan 05, 2015 7:45 am

UART BAUDRATE

Postby piotrva » Sat Feb 14, 2015 6:45 am

Dear all,

I want to know where I can find gobal setting of BAUDRATE (os_sprintf related etc.).

Kind regards
Peter

ESP_Faye
Posts: 1646
Joined: Mon Oct 27, 2014 11:08 am

Re: UART BAUDRATE

Postby ESP_Faye » Sun Feb 15, 2015 10:26 am

Hi,

Thanks for your interest in ESP8266 !

Please refer to this http://bbs.espressif.com/viewtopic.php?f=10&t=182

piotrva
Posts: 9
Joined: Mon Jan 05, 2015 7:45 am

Re: UART BAUDRATE

Postby piotrva » Sun Feb 15, 2015 9:24 pm

Thanks for info - i tried using this function and modifying uart_init as you mentioned in the post - but still sf is not ok at all:

Code: Select all

void user_init(void)
{
   uart_init(BIT_RATE_115200,BIT_RATE_115200);
   os_printf("SDK version:%s\n", system_get_sdk_version());

   os_printf("Module Test\nChip_id: %lu\n", system_get_chip_id());
   wifi_set_opmode(STATIONAP_MODE);//STA + AP (page 25)
//(...)

}

Both os_printf are sent using default BaudRate 74880.
Then messages about opmode is sent using 115200.

kmakhil90
Posts: 4
Joined: Wed Dec 02, 2015 6:19 pm

Re: UART BAUDRATE

Postby kmakhil90 » Tue Jun 13, 2017 11:19 pm

Hi,

For me too the problem same. I cannot edit the badrate by driver included in nonos as well as rtos sdk.

RogerFL
Posts: 16
Joined: Fri Jul 24, 2015 10:32 pm

Re: UART BAUDRATE

Postby RogerFL » Mon Jan 01, 2018 12:00 am

I fixed this issue by adding a 1 ms delay after initializing UART:

Code: Select all

uart_init(115200, 115200);
os_delay_us(1000);
Roger Collins
Espressif fan and developer of flame boss smoker controller

Who is online

Users browsing this forum: No registered users and 10 guests