sdk:ESP8266 NONOS SDK V1.5.4___支不支持 upgrade API???

Sam Shen
Posts: 10
Joined: Tue Jun 21, 2016 4:16 pm

sdk:ESP8266 NONOS SDK V1.5.4___支不支持 upgrade API???

Postby Sam Shen » Tue Apr 25, 2017 4:47 pm

各位:
ESP8266 NONOS SDK V1.5.4版本的SDK,是否支持upgrade API? 打算实现fota升级。

include/upgrade.h定义了升级使用的API。lib目录下也有libupgrade.a文件。

但是在user_main.c中调用对应函数,编译报错。
/cygdrive/d/wifi_title/syt_work/ESP8266_NONOS_SDK_1.5.4/app/user/user_main.c:256: undefined reference to `system_upgrade_start'
Attachments
nonos154_err.png

jinhucn
Posts: 20
Joined: Wed Dec 23, 2015 12:06 pm

Re: sdk:ESP8266 NONOS SDK V1.5.4___支不支持 upgrade API???

Postby jinhucn » Wed Apr 26, 2017 8:59 am

在makefile里面加-lupgrade

Sam Shen
Posts: 10
Joined: Tue Jun 21, 2016 4:16 pm

Re: sdk:ESP8266 NONOS SDK V1.5.4___支不支持 upgrade API???

Postby Sam Shen » Fri May 12, 2017 10:08 am

jinhucn wrote:在makefile里面加-lupgrade

谢谢,确实这样,加上就OK了,upgrade 功能已经搞定。

levi
Posts: 1
Joined: Thu May 09, 2019 5:27 pm

Re: sdk:ESP8266 NONOS SDK V1.5.4___支不支持 upgrade API???

Postby levi » Thu May 09, 2019 5:35 pm

Sam Shen wrote:
jinhucn wrote:在makefile里面加-lupgrade

谢谢,确实这样,加上就OK了,upgrade 功能已经搞定。

请问一下是在makefile中的具体哪个位置加-lupgrade

Her Mary
Posts: 384
Joined: Mon Oct 27, 2014 11:09 am

Re: sdk:ESP8266 NONOS SDK V1.5.4___支不支持 upgrade API???

Postby Her Mary » Fri May 24, 2019 5:55 pm

加在 LINKFLAGS _eagle.app.v6 区域看可以了么

Who is online

Users browsing this forum: No registered users and 8 guests