esptool: Permission denied

Posts: 1
Joined: Wed Apr 26, 2017 2:04 am

esptool: Permission denied

Postby davidthe16 » Wed Apr 26, 2017 2:17 am

I'm trying to compile a project with esp_iot_sdk 1.30 for a school POC project.
but I get `esptool: Permission denied` every time I do `make`.

Code: Select all

david@david-VirtualBox:~/myprojects/esp8266-injection-example$ ls -al
    total 36
    drwxrwxr-x  7 david david 4096 אפר 24 20:40 .
    drwxrwxr-x  6 david david 4096 אפר 20 19:38 ..
    drwxrwxr-x  2 david david 4096 אפר 20 16:51 driver
    drwxrwxr-x 12 david david 4096 אפר 24 20:40 esp_iot_sdk_v1.3.0
    drwxrwxr-x  8 david david 4096 אפר 20 16:51 .git
    drwxrwxr-x  3 david david 4096 אפר 20 16:51 include
    -rw-rw-r--  1 david david 4069 אפר 20 19:44 Makefile
    -rw-rw-r--  1 david david  597 אפר 20 16:51
    drwxrwxr-x  2 david david 4096 אפר 20 16:51 user
    david@david-VirtualBox:~/myprojects/esp8266-injection-example$ sudo make clean
    david@david-VirtualBox:~/myprojects/esp8266-injection-example$ sudo make
    CC driver/uart.c
    CC user/user_main.c
    AR build/app_app.a
    LD build/app.out
    FW firmware/0x00000.bin
    /bin/sh: 1: /home/david/myprojects/esptool: Permission denied
    Makefile:109: recipe for target 'firmware/0x00000.bin' failed
    make: *** [firmware/0x00000.bin] Error 126

There is no global variable `ESPTOOL`, or `FW_TOOL`:

Code: Select all

 david@david-VirtualBox:~/myprojects/esp8266-injection-example$ echo $FW_TOOL
    david@david-VirtualBox:~/myprojects/esp8266-injection-example$ echo $ESPTOOL

I'm using esp-open sdk.
I downloaded esptool from here : (according to step 2 here: and made that my FW_TOOL

I'm tying to compile this project : for the POC project.

I tried this solution but it didn't work (I tried to do it for the esptool folder in esp-open-sdk, and for the esptool folder I downloaded above) viewtopic.php?p=12465

I tried to do sudo chmod 777 esptool, for both esptool folders

And nothing works for me

NOTE: If I do ` chip_id` I do get a response.
Also I was able to burn `blinky` demo with the new SDK (that came with esp-open-sdk). So it looks like there is a problem with this sdk specificly...

I am also part of `dialout` group

Code: Select all

    david@david-VirtualBox:~/myprojects/esp8266-injection-example$ lsusb
    Bus 001 Device 003: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
    Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    david@david-VirtualBox:~/myprojects/esp8266-injection-example$ ls -al /dev/ttyUSB0
    crw-rw---- 1 root dialout 188, 0 אפר 24 20:20 /dev/ttyUSB0
    david@david-VirtualBox:~/myprojects/esp8266-injection-example$ groups
    david adm dialout cdrom sudo dip plugdev lpadmin sambashare

Please help!

Here is my make file:

Code: Select all

 david@david-VirtualBox:~/myprojects/esp8266-injection-example$ cat Makefile
    # tnx to mamalala
    # Changelog
    # Changed the variables to include the header file directory
    # Added global var for the XTENSA tool root
    # This make file still needs some work.
    # Output directors to store intermediate compiled files
    # relative to the project directory
    BUILD_BASE      = build
    FW_BASE         = firmware
    # Base directory for the compiler
    XTENSA_TOOLS_ROOT ?= ~/myprojects/esp-open-sdk/xtensa-lx106-elf/bin

    # base directory of the ESP8266 SDK package, absolute
    SDK_BASE        ?= $(CURDIR)/esp_iot_sdk_v1.3.0 path and port
    ESPTOOL         ?= ~/myprojects/esp-open-sdk/esptool/
    ESPPORT         ?= /dev/ttyUSB0
    # name for the target project
    TARGET          = app

        # which modules (subdirectories) of the project to include in compiling
        MODULES         = driver user
    EXTRA_INCDIR    = include ~/myprojects/esp-open-sdk/xtensa-lx106-elf/include
    # libraries used in this project, mainly provided by the SDK
    LIBS            = c gcc hal pp phy net80211 lwip wpa main
    # compiler flags using during compilation of source files
    CFLAGS          = -Os -g -O2 -Wpointer-arith -Wundef -Werror -Wl,-EL -fno-inline-functions -nostdlib -mlongcalls -mtext-section-literals  -D__ets__ -DICACHE_FLASH
    # linker flags used to generate the main object file
    LDFLAGS         = -nostdlib -Wl,--no-check-sections -u call_user_start -Wl,-static
    # linker script used for the above linkier step
    LD_SCRIPT       =
    # various paths from the SDK used in this project
    SDK_LIBDIR      = lib
    SDK_LDDIR       = ld
    SDK_INCDIR      = include include/json
    # we create two different files for uploading into the flash
    # these are the names and options to generate them
    FW_FILE_1       = 0x00000
    FW_FILE_1_ARGS  = -bo $@ -bs .text -bs .data -bs .rodata -bc -ec
    FW_FILE_2       = 0x40000
    FW_FILE_2_ARGS  = -es .irom0.text $@ -ec
    # select which tools to use as compiler, librarian and linker
    CC              := $(XTENSA_TOOLS_ROOT)/xtensa-lx106-elf-gcc
    AR              := $(XTENSA_TOOLS_ROOT)/xtensa-lx106-elf-ar
    LD              := $(XTENSA_TOOLS_ROOT)/xtensa-lx106-elf-gcc
    #### no user configurable options below here
    FW_TOOL         ?= ~/myprojects/esptool
    SRC_DIR         := $(MODULES)
    BUILD_DIR       := $(addprefix $(BUILD_BASE)/,$(MODULES))
    SDK_LIBDIR      := $(addprefix $(SDK_BASE)/,$(SDK_LIBDIR))
    SDK_INCDIR      := $(addprefix -I$(SDK_BASE)/,$(SDK_INCDIR))
    SRC             := $(foreach sdir,$(SRC_DIR),$(wildcard $(sdir)/*.c))
    OBJ             := $(patsubst %.c,$(BUILD_BASE)/%.o,$(SRC))
    LIBS            := $(addprefix -l,$(LIBS))
    APP_AR          := $(addprefix $(BUILD_BASE)/,$(TARGET)_app.a)
    TARGET_OUT      := $(addprefix $(BUILD_BASE)/,$(TARGET).out)
    LD_SCRIPT       := $(addprefix -T$(SDK_BASE)/$(SDK_LDDIR)/,$(LD_SCRIPT))
    INCDIR  := $(addprefix -I,$(SRC_DIR))
    EXTRA_INCDIR    := $(addprefix -I,$(EXTRA_INCDIR))
    MODULE_INCDIR   := $(addsuffix /include,$(INCDIR))
    FW_FILE_1       := $(addprefix $(FW_BASE)/,$(FW_FILE_1).bin)
    FW_FILE_2       := $(addprefix $(FW_BASE)/,$(FW_FILE_2).bin)
    V ?= $(VERBOSE)
    ifeq ("$(V)","1")
    Q :=
    vecho := @true
    Q := @
    vecho := @echo
    vpath %.c $(SRC_DIR)
    define compile-objects
    $1/%.o: %.c
            $(vecho) "CC $$<"
            $(Q) $(CC) $(INCDIR) $(MODULE_INCDIR) $(EXTRA_INCDIR) $(SDK_INCDIR) $(CFLAGS)  -c $$< -o $$@
    .PHONY: all checkdirs flash clean
    all: checkdirs $(TARGET_OUT) $(FW_FILE_1) $(FW_FILE_2)
    $(FW_FILE_1): $(TARGET_OUT)
            $(vecho) "FW $@"
            $(Q) $(FW_TOOL) -eo $(TARGET_OUT) $(FW_FILE_1_ARGS)
    $(FW_FILE_2): $(TARGET_OUT)
            $(vecho) "FW $@"
            $(Q) $(FW_TOOL) -eo $(TARGET_OUT) $(FW_FILE_2_ARGS)
    $(TARGET_OUT): $(APP_AR)
            $(vecho) "LD $@"
            $(Q) $(LD) -L$(SDK_LIBDIR) $(LD_SCRIPT) $(LDFLAGS) -Wl,--start-group $(LIBS) $(APP_AR) -Wl,--end-group -o $@
    $(APP_AR): $(OBJ)
            $(vecho) "AR $@"
            $(Q) $(AR) cru $@ $^
    checkdirs: $(BUILD_DIR) $(FW_BASE)
            $(Q) mkdir -p $@
            $(Q) mkdir -p $@
    flash: firmware/0x00000.bin firmware/0x40000.bin
            -$(ESPTOOL) --port $(ESPPORT) write_flash 0x00000 firmware/0x00000.bin 0x40000 firmware/0x40000.bin
            $(Q) rm -f $(APP_AR)
            $(Q) rm -f $(TARGET_OUT)
            $(Q) rm -rf $(BUILD_DIR)
            $(Q) rm -rf $(BUILD_BASE)
            $(Q) rm -f $(FW_FILE_1)
            $(Q) rm -f $(FW_FILE_2)
            $(Q) rm -rf $(FW_BASE)

User avatar
Posts: 467
Joined: Wed Jun 29, 2016 7:17 pm
Location: India

Re: esptool: Permission denied

Postby pratik » Sun May 14, 2017 8:37 pm

Did you try executing the esptool from somewhere else? Like from your desktop or something?
Pratik Panda

Custom firmware, Knowledge base and freelancing (ESP8266/ESP32):

Posts: 2
Joined: Fri May 12, 2017 12:03 am
Location: Latvia

View first unread post

Postby JamesRit » Mon May 22, 2017 7:41 pm

Its possible to make the option of view first unread post available in topics with record games?

Thank you

Who is online

Users browsing this forum: MSN [Bot] and 10 guests