Page 1 of 1

Should data type UartBautRate not be UartBaudRate?

Posted: Sun Jul 05, 2015 1:42 am
by kolban
Am studying the SDK and found the API for uart_init(). This takes parameters of type "UartBautRate". I thought this was just a typo in the docs but it appears to be the actual name of the data type. Should this not be "UartBaudRate"?

Re: Should data type UartBautRate not be UartBaudRate?

Posted: Tue Jul 07, 2015 5:51 am
by tve
Unfortunately there are LOTS of misspellings in the SDK functions... For example, one of the most used functions, espconn_sent, is similarly misspelled..
It would be awesome if Espressif could publish the API docs in a wiki, then we (the community) could fix the typos and miswordings, and perhaps correctly explain what the functions do...

Re: Should data type UartBautRate not be UartBaudRate?

Posted: Tue Jul 07, 2015 6:17 am
by kolban
Howdy ... its one thing having typos in the docs. They can easily be fixed.... however, this post was about what appears to be a typo being present in the actual SDK code that is meant to be consumed by users.

For example, as of right now, if I want to create a variable that can be passed into "uart_init", I have to code:

Code: Select all

UartBautRate myVariable;


So ... if this is really an accidental typo, then we can't simply change the value without potentially breaking existing code that may use this data type name. If it is a typo, then my vote would be to change the data type name and inform folks that they may have to code change before deploying apps.

Now ... being a dumb mono-language speaker, I look at Chinese writing and wouldn't even begin to know where to start to say something was spelled incorrectly. In fact, I'm so ignorant that I can't even tell you if it is possible to make spelling mistakes with logograms. I can easily see how a translation of the pronounced word "baud" (b -od) becomes "baut" (b -ot).

Re: Should data type UartBautRate not be UartBaudRate?

Posted: Tue Jul 07, 2015 5:44 pm
by costaud
kolban wrote:Howdy ... its one thing having typos in the docs. They can easily be fixed.... however, this post was about what appears to be a typo being present in the actual SDK code that is meant to be consumed by users.

For example, as of right now, if I want to create a variable that can be passed into "uart_init", I have to code:

Code: Select all

UartBautRate myVariable;


So ... if this is really an accidental typo, then we can't simply change the value without potentially breaking existing code that may use this data type name. If it is a typo, then my vote would be to change the data type name and inform folks that they may have to code change before deploying apps.

Now ... being a dumb mono-language speaker, I look at Chinese writing and wouldn't even begin to know where to start to say something was spelled incorrectly. In fact, I'm so ignorant that I can't even tell you if it is possible to make spelling mistakes with logograms. I can easily see how a translation of the pronounced word "baud" (b -od) becomes "baut" (b -ot).



Oops...
:o :o :o :o :o :o

Re: Should data type UartBautRate not be UartBaudRate?

Posted: Wed Jul 08, 2015 10:29 am
by ESP_Faye
Hi,

So sorry for our poor English.. :oops:

Dear tve, if you have any advice about API Doc please feel free to let us know, you could send email to support-at@espressif.com, sorry for the inconvenience.