Standard Setup of Toolchain for Mac OS - blows up on step 1

AndreiC
Posts: 14
Joined: Sat May 27, 2017 7:04 am

Standard Setup of Toolchain for Mac OS - blows up on step 1

Postby AndreiC » Tue Feb 09, 2021 2:18 am

MacOS 10.14.6 (Mojave)

Step 1 on https://docs.espressif.com/projects/esp ... setup.html

sudo easy_install pip

blows up with:

Code: Select all

Corundum:workspace andreichichak$ sudo easy_install pip
Searching for pip
Reading https://pypi.python.org/simple/pip/
Best match: pip 21.0.1
Downloading https://files.pythonhosted.org/packages/b7/2d/ad02de84a4c9fd3b1958dc9fb72764de1aa2605a9d7e943837be6ad82337/pip-21.0.1.tar.gz#sha256=99bbde183ec5ec037318e774b0d8ae0a64352fe53b2c7fd630be1d07e94f41e5
Processing pip-21.0.1.tar.gz
Writing /tmp/easy_install-euDjAv/pip-21.0.1/setup.cfg
Running pip-21.0.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-euDjAv/pip-21.0.1/egg-dist-tmp-PierV8
/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'project_urls'
  warnings.warn(msg)
/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
  warnings.warn(msg)
warning: no files found matching 'docs/docutils.conf'
warning: no previously-included files found matching '.coveragerc'
warning: no previously-included files found matching '.mailmap'
warning: no previously-included files found matching '.appveyor.yml'
warning: no previously-included files found matching '.travis.yml'
warning: no previously-included files found matching '.readthedocs.yml'
warning: no previously-included files found matching '.pre-commit-config.yaml'
warning: no previously-included files found matching 'tox.ini'
warning: no previously-included files found matching 'noxfile.py'
warning: no files found matching '*.css' under directory 'docs'
warning: no previously-included files found matching 'src/pip/_vendor/six'
warning: no previously-included files found matching 'src/pip/_vendor/six/moves'
warning: no previously-included files matching '*.pyi' found under directory 'src/pip/_vendor'
no previously-included directories found matching '.github'
no previously-included directories found matching '.azure-pipelines'
no previously-included directories found matching 'docs/build'
no previously-included directories found matching 'news'
no previously-included directories found matching 'tasks'
no previously-included directories found matching 'tests'
no previously-included directories found matching 'tools'
  File "build/bdist.macosx-10.14-intel/egg/pip/_internal/configuration.py", line 167
    raise ConfigurationError(f"No such key - {key}")
                                                  ^
SyntaxError: invalid syntax

  File "build/bdist.macosx-10.14-intel/egg/pip/_internal/network/auth.py", line 202
    ), f"Could not load credentials from url: {original_url}"
                                                            ^
SyntaxError: invalid syntax

  File "build/bdist.macosx-10.14-intel/egg/pip/_internal/network/session.py", line 321
    msg = f'adding trusted host: {host!r}'
                                         ^
SyntaxError: invalid syntax

  File "build/bdist.macosx-10.14-intel/egg/pip/_internal/network/lazy_wheel.py", line 193
    headers['Range'] = f'bytes={start}-{end}'
                                            ^
SyntaxError: invalid syntax

  File "build/bdist.macosx-10.14-intel/egg/pip/_internal/utils/logging.py", line 123
    prefix = f"{self.formatTime(record)} "
                                         ^
SyntaxError: invalid syntax

  File "build/bdist.macosx-10.14-intel/egg/pip/_internal/utils/misc.py", line 117
    return f"{sys.executable} -m pip"
                                    ^
SyntaxError: invalid syntax


and so on.

AndreiC
Posts: 14
Joined: Sat May 27, 2017 7:04 am

Re: Standard Setup of Toolchain for Mac OS - blows up on step 1

Postby AndreiC » Tue Feb 09, 2021 12:08 pm

More on this.

The instructions should probably say that you should have python version 3.8++ installed. That comes later in the instructions, after all of this stuff has already caused grief.

Cmake needs to be installed as well.

Who is online

Users browsing this forum: No registered users and 9 guests