Fail when trying to flash ESP13 firmware

flacidsnake
Posts: 1
Joined: Sun Apr 29, 2018 2:46 am

Fail when trying to flash ESP13 firmware

Postby flacidsnake » Sun Apr 29, 2018 3:04 am

Hi,

I'm trying to use this Arduino Leonardo

https://www.thethingsnetwork.org/docs/devices/uno/

With this ESP13 shield
https://www.amazon.es/dp/B077XCNX5B/ref=pe_3310721_185740151_TE_item


The shield I received it's different to the one you can see at the link. It's an ESP-WROOM-02 and it came with the DoIt firmware. The DoitWiFi_config webserver says it's version 2.2 based on ESP8266 SDK 1.4.0 (2015).

I uploaded this sketch to Leonardo to use it as a USBTTL in order to flash the firmware of the shield.

Code: Select all

void setup() {
  Serial.begin(115200);
  Serial1.begin(115200);
}

void loop() {
  if (Serial.available()) {      // If anything comes in Serial (USB),
    Serial1.write(Serial.read());   // read it and send it out Serial1 (pins 0 & 1)
  }

  if (Serial1.available()) {     // If anything comes in Serial1 (pins 0 & 1)
    Serial.write(Serial1.read());   // read it and send it out Serial (USB)
  }
}


I'm trying to flash the Doit firmware to the AT firmware included in the latest version of ESP8266_NONOS_SDK.

I get "Chip sync error esp_sync_blocking". Both Leonardo and the shield are set at 115200 (I configured the shield using the DoitWiFi_config webserver).

Links below are pictures of the board, the shield and the results I got from ESP Flash Download Tool 3.6.4.
https://cdn.pbrd.co/images/HiBlbbi.jpg
https://cdn.pbrd.co/images/HiBlO7B.jpg
https://cdn.pbrd.co/images/HiBmmZX.jpg
https://cdn.pbrd.co/images/HiBng3h.jpg
https://cdn.pbrd.co/images/HiKdfZr.png

Who is online

Users browsing this forum: No registered users and 22 guests