[SOLVED]ESP01 - AT 0.50 - Can't save baud rate change on 4Mbit

Posts: 2
Joined: Mon Dec 14, 2015 6:59 am

Re: [SOLVED]ESP01 - AT 0.50 - Can't save baud rate change on 4Mbit

Postby PPahl » Wed Dec 16, 2015 3:28 am

Same problem here,the baud rate can't been saved at newer AT-firmwares.
I've tested several versions, even the one suggested here viewtopic.php?f=16&t=977&sid=82d6e5eaa194ce659812a876727e60d9#p3434
Had to go back to an old firmware 9.2.2 from AiThinker, but that version is too unstable as it could be used seriously.
All this stuff is very confusing and frustrating, I'm not even able to say which version of chip I have - 512kB? 1MB? No clue how to check this out.
At the moment the esp is useless for me, it only eats time and time and time for testing without results.

Posts: 2
Joined: Wed Jan 03, 2018 4:09 am

Re: [SOLVED]ESP01 - AT 0.50 - Can't save baud rate change on 4Mbit

Postby phrxmd » Wed Jan 03, 2018 4:13 am

For what it's worth, I had the same problem with many different firmwares.
In the end I solved it by flashed the newest version (2.0.0, with AT 1.3.0), even though the documentation says it needs 8 MBit it seems to be working fine so far on a 4 MBit chip. I used this guide: https://syonyk.blogspot.com/2016/11/installing-latest-at-firmware-on-4mbit.html#comment-form. So far, version 2.0.0 is the only one that will save the configuration on AT+UART_DEF etc. in a way that survives a reset.

Who is online

Users browsing this forum: No registered users and 2 guests