Help setting up ESP8266 RTOS SDK (xtensa not found error)?

ShaneKirkbride
Posts: 6
Joined: Tue Apr 05, 2016 10:48 pm

Help setting up ESP8266 RTOS SDK (xtensa not found error)?

Postby ShaneKirkbride » Wed May 04, 2016 1:18 am

Hello,
I set up a virtual box that runs Lubuntu. I'm created the shared drive. I then pulled the RTOS SDK from the git hub. I moved the example/websocket_demo up one level.
I go to compile and I get this error:

Code: Select all

make[1]: xtensa-lx106-elf-gcc: Command not found
make[1]: *** [.output/eagle/debug/obj/user_main.o] Error 127
make[1]: Leaving directory `/mnt/Share/ESP8266_RTOS_SDK/websocket_demo/user'
make: *** [.subdirs] Error 2

Here is a screen shot of what I'm doing
[img]
screenshot%20error.png
[/img]

I've added xtensa into my path and it exists in my /opt directory. I can't figure out how to make it recognize it so this will compile. Can anyone help me resolve this?
Thanks,
~Shane
Attachments
screenshot error.png

ESP_Faye
Posts: 1641
Joined: Mon Oct 27, 2014 11:08 am

Re: Help setting up ESP8266 RTOS SDK (xtensa not found error)?

Postby ESP_Faye » Tue May 10, 2016 10:15 am

Hi,

Code: Select all

make[1]: xtensa-lx106-elf-gcc: Command not found

It means that you do not have gcc in your PATH.

Here is the ESP8266 Getting Started Guide. You can follow the guide to setup the compiler.

Thanks for your interest in ESP8266 !

ShaneKirkbride
Posts: 6
Joined: Tue Apr 05, 2016 10:48 pm

Re: Help setting up ESP8266 RTOS SDK (xtensa not found error)?

Postby ShaneKirkbride » Thu Jun 16, 2016 6:29 am

Hi,
Thanks for your help. I got it all worked out. I ended up using the open-sdk. It works pretty well. I have another issue trying to update the ESP with the FLAS Download too. That post is in a different thread.
~Shane

Who is online

Users browsing this forum: No registered users and 15 guests