ESP8285 cannot run into user.bin sometimes

Nicholas3388
Posts: 10
Joined: Sun Jan 03, 2016 12:57 pm

ESP8285 cannot run into user.bin sometimes

Postby Nicholas3388 » Thu Nov 15, 2018 6:13 pm

Hi, My ESP8285 sometimes cannot run into user2.bin when the firmware is upgraded via FOTA. The logs are as follow:

ets Jan 8 2013,rst cause:2, boot mode:(3,0)

load 0x40100000, len 2592, room 16
tail 0
chksum 0xf3
load 0x3ffe8000, len 764, room 8
tail 4
chksum 0x92
load 0x3ffe82fc, len 676, room 4
tail 0
chksum 0x22
csum 0x22

2nd boot version : 1.7(5d6f877)
SPI Speed : 40MHz
SPI Mode : DOUT
SPI Flash Size & Map: 8Mbit(512KB+512KB)
jump to run user2 @ 81000

c炸A*蚯ny+EhQ贻?kt況嚝 栩?*蜈G1況猼@*r鸔?11)&?11)&?
t鸔?11??11?@猂jrA(!婼藂嬓汌沊薗鷁蔘*薗K↖*E??)dP沎隥A??E"HhI蜛,鬧Mor,R??┰vA?5y*e?n?U"HhI蜛,Z[MoR R?
5?癃A?5?U?n?EHhi預 P[M忽A,P[I 峇(龐P嘙鷔!B=d)奠=a€ j吼?e??%謵[闑-暶?敳機-Aea*U菼,怵徹Em楸{郲歗
1A韡氁讈(11堷c請A*蚯nY+EHq曩?Kt汻嚝 栩韁0*蜈G1涷?)&?11)&?111)&?T跶?1)勻1110\0


As you can see from the logs, the system is about to jump to user2, and then crash immediately and stop running. When I reboot the device by pressing the reset button manually, it will run without problem. This issue happen sometimes. Is there anyone know how to handle this issue?

Her Majesty
Posts: 349
Joined: Mon Oct 27, 2014 11:09 am

Re: ESP8285 cannot run into user.bin sometimes

Postby Her Majesty » Tue Dec 11, 2018 8:45 pm

The same user2.bin, sometimes it runs successfully, sometimes it fails? Maybe the log of success running can tell something.

AgentSmithers
Posts: 125
Joined: Sat Apr 01, 2017 1:21 am
Contact:

Re: ESP8285 cannot run into user.bin sometimes

Postby AgentSmithers » Thu Dec 13, 2018 4:54 am

Are you running Firmware over the air?

Who is online

Users browsing this forum: No registered users and 10 guests