ESP-01 not working after firmware update download/flash

Posts: 2
Joined: Sat Sep 21, 2019 7:25 am

ESP-01 not working after firmware update download/flash

Postby Abomin3V3L » Sat Sep 21, 2019 7:43 am

ESP-01 not working after firmware update/download/flash

Hi. I am new in this forum.
I am developing products which use the ESP-01 module (the little black board). The products use PIC32MX microcontrollers and currently I am using the PIC/ESP-01 as webserver.

I have 7 modules here (8Mbit flash - 25Q80A) and now I want to update the firmware of them. When I send AT+GMR command to them they respond with the following:
"AT version: 8 2015 14:45:58)..SDK version: 1.3.0..Ai-Thinker Technology Co.,Ltd...Build Sep 11 2015 11:48:04..OK"

I have tried to flash 2 of the 7 modules, with different addresses on the "ESP8266 DOWNLOAD TOOL V3.6.6". During the download the blue led was blinking for both.
In the pictures below are shown the 2 combinations of addresses that I have tried, one combination for each module.
To flash them, I have tied GPIO0 to GND. After download process showed FINISH on the ESP8266 DOWNLOAD TOOL I did removed GPIO0 from GND, did a power down and after some seconds a power up. From this point on the modules seems to be not working anymore with my current application, they do not respond to AT commands anymore. The blue led blink one time when I power the circuit, and the module is also outputing a 26MHz signal on GPIO0 (strange).
As I have a debug UART port on the PIC32MX to communicate to the PC, I have set the baudrate of the PIC32MX-ESP-interface UART to 74880bps, and when I power the circuit, both modules are sending the following to the PIC32MX:
"..ets Jan 8 2013, rst cause:1, boot mode: (3,6) ....ets_main.c .. ets Jan 8 2013, rst cause:2 boot mode: (3,6)....ets_main.c"

PICTURES: see screen_1.png and screen_2.png attached...

What files I used?
I entered here: ... master/bin
Then downloaded these:
- boot_v1.7.bin
- blank.bin
- esp_init_data_default_v08.bin
Then I entered on this subfolder:
And downloaded this:

OBS: Its not a power supply issue, I have a good layout with good ground plane, large tracks for 3.3V signal, and have 2x 22uF/10V/0805 caps very close to the VCC pin of the module in the PCB.

Are my ESP-01 modules damaged now?
What I am doing wrong? And how to do correctly?

version_AT+GMR.png (3.89 KiB) Viewed 5989 times
74880_bps.png (2.81 KiB) Viewed 5989 times

Posts: 1
Joined: Wed Jan 29, 2020 10:49 pm

Re: ESP-01 not working after firmware update download/flash

Postby dinesh.thanth » Wed Jan 29, 2020 10:55 pm

I have also getting same error, Any one can help me ??

ets Jan 8 2013,rst cause:1, boot mode:(3,6)

load 0x40100000, len 1856, room 16
tail 0
chksum 0xef
load 0x00000000, len 0, room 8
tail 0
chksum 0xef
load 0x00000000, len 0, room 0
tail 0
chksum 0xef
csum 0xef
csum err


Posts: 1
Joined: Fri Feb 07, 2020 7:37 am

Re: ESP-01 not working after firmware update download/flash

Postby gtc » Fri Feb 07, 2020 11:26 am

I am having the same issue. Have you found the solution to restore factory default on the device?
I am no longer able to get a "Ready" from the AT command

Thanks for any info you have

Her Mary
Posts: 446
Joined: Mon Oct 27, 2014 11:09 am

Re: ESP-01 not working after firmware update download/flash

Postby Her Mary » Fri Feb 28, 2020 11:11 am

How about download the latest AT bin?Download the bin in the “factory” folder to address 0, and restart the module to see if it works fine. ...

Who is online

Users browsing this forum: No registered users and 7 guests