GET /update?api_key doesn't return anything

squalo
Posts: 1
Joined: Sat Dec 21, 2019 6:04 am

GET /update?api_key doesn't return anything

Postby squalo » Sat Dec 21, 2019 6:09 am

Hi,

i am using ESP8266 with STM32F4. I am trying to send data to thingspeak using

Code: Select all

GET /update?api_key
command. I have to see

Code: Select all

>
in my buffer before use

Code: Select all

GET /update?api_key
command. And i can see

Code: Select all

>
in my buffer. Then, i use these lines to send data:

Code: Select all

sprintf(gidecekdeger,"GET /update?api_key=A0AISRD6SB8SKH4J&field1=%d\r\n",10);

HAL_UART_Transmit(&huart2, (uint8_t *)gidecekdeger,strlen(gidecekdeger), 500);

but these lines returns nothing. (i put a breakpoint, so i am sure that code reaches here)

where is my mistake?

Her Mary
Posts: 450
Joined: Mon Oct 27, 2014 11:09 am

Re: GET /update?api_key doesn't return anything

Postby Her Mary » Mon Dec 30, 2019 5:47 pm


annawoods
Posts: 1
Joined: Wed Feb 12, 2020 12:34 pm
Contact:

Re: GET /update?api_key doesn't return anything

Postby annawoods » Wed Feb 12, 2020 12:38 pm

thank you Her Mary for your help
Anna
Online Review Expert

tia65
Posts: 1
Joined: Tue Feb 25, 2020 11:05 pm
Location: United Kingdom
Contact:

Re: GET /update?api_key doesn't return anything

Postby tia65 » Tue Feb 25, 2020 11:18 pm

Her Mary wrote:Could this example help? https://bbs.espressif.com/viewtopic.php?f=61&t=560


I have tried this and I have to say that its working fine on my side :)

Thanks and keep providing help on this amazing platform!

Who is online

Users browsing this forum: ZacharyTreva and 4 guests