ESP8285H16 - unable to run AT bin 1.7.2

michael.ughetti
Posts: 2
Joined: Fri Nov 10, 2017 11:27 pm

ESP8285H16 - unable to run AT bin 1.7.2

Postby michael.ughetti » Thu Mar 05, 2020 6:29 pm

Hello,

I have a design working with standard ESP8285 with 8Mbits flash. I bought the new ESP8285H16 on Mouser last week for a new batch of the same design. I've downloaded last "Download tool" and "AT firmware" but couldn't get it to work.
I've attached a picture with the programming tool's configuration and result.
I've added a terminal window on the bottom left, this is what I receive after a reset.

Seems pretty good BUT the module doesn't respond to AT commands (I change for 115200bps of course). It doesn't start the Wifi AP like on previous version.

Could you please help me understand where is the issue ?
I assume it has something to do with addresses.

Best regards,
Michaël Ughetti
Attachments
ESP8285H16.png

Her Mary
Posts: 446
Joined: Mon Oct 27, 2014 11:09 am

Re: ESP8285H16 - unable to run AT bin 1.7.2

Postby Her Mary » Fri Mar 27, 2020 7:50 pm

The GPIO0 should be high level to run the firmware, low level to burn the firmware into flash.
Have you set GPIO0 to be high to run it?

Dangar
Posts: 1
Joined: Fri Apr 17, 2020 7:04 am

Re: ESP8285H16 - unable to run AT bin 1.7.2

Postby Dangar » Wed Apr 22, 2020 2:14 pm

Hi, I have an ESP8285 with the 1MByte/8MBit flash, it came with the following AT firmware:

AT version:1.1.0.0(May 11 2016 18:09:56)

SDK version:1.5.4(baaeaebb)

compile time:May 20 2016 15:08:19

I want to be able to use the AT+CIPSNTPTIME functions, but it appears my version doesn't have it...

+CIPSNTPTIME?
ERROR

The OTA update doesn't appear to be an option either, I send "AT+CIUPDATE" and the response is "ERROR"

I am definitely connected to the internet in station mode via my home access port as I can ping outside addresses with the AT+PING command.

I can't seem to update the firmware either. It appears that I have wired GPIO0 correctly, as when I hold it to ground during a reset then I can't talk to it in AT mode, so I presume it is in flash mode.

But whatever I try I get this error response from the firmware updater:

CONNECT BAUD: 115200
============
....._____....._____....._____....._____....._____....._____....._____....._____....._____....._____[2020-04-22 16:09:33,619][ESP8266Loader_spi[1]][espDownloader.py][line:368][ERROR]: Chip sync error: Failed to connect to ESP8285: Timed out waiting for packet header
[2020-04-22 16:09:33,621][ESP8266Loader_spi[1]][espDownloader.py][line:459][ERROR]: ESP8285 Chip sync error esp_sync_blocking.


Can anyone tell me what I'm doing wrong???

Her Mary
Posts: 446
Joined: Mon Oct 27, 2014 11:09 am

Re: ESP8285H16 - unable to run AT bin 1.7.2

Postby Her Mary » Wed Apr 22, 2020 2:58 pm

With 1MB flash, you can only download the AT v1.6.2. https://www.espressif.com/sites/default ... .6.2_0.zip
Maybe try to download it with the latest tool? https://www.espressif.com/sites/default ... v3.6.8.zip

Who is online

Users browsing this forum: No registered users and 10 guests