Disable echo on UART0

Pato
Posts: 28
Joined: Sat Mar 24, 2018 12:52 am

Disable echo on UART0

Postby Pato » Fri Apr 06, 2018 10:10 pm

Hello,

On the ESP8266-12 with the NONOS-SDK-2.2.0, every char I send on the RX pin of the UART0 is reprinted/echoed on the TX pin.

How to disable this annoying echo ?
Thx !

(I suspected the "loopback" feature to be enabled by default, but clearing bit 14 of UART_CONF0(0) didn't help: SET_PERI_REG_MASK(UART_CONF0(0), UART_LOOPBACK); )

Pato
Posts: 28
Joined: Sat Mar 24, 2018 12:52 am

Re: Disable echo on UART0

Postby Pato » Mon Jul 23, 2018 8:34 pm

Okay,

most of these issues were because the code in uart.c - which I believed to be a simple classic UART driver - actually implemented some processing of the bytes like reprinting them.

I simply removed most of the code in this file to write my own driver.
(https://bbs.espressif.com/viewtopic.php ... 191#p22191)
Last edited by Pato on Wed Jul 25, 2018 3:19 pm, edited 2 times in total.

AgentSmithers
Posts: 119
Joined: Sat Apr 01, 2017 1:21 am
Contact:

Re: Disable echo on UART0

Postby AgentSmithers » Wed Jul 25, 2018 4:25 am

Pato wrote:Okay,

most of these issues were because of the code in uart.c, which I believed to be a simple classic UART drive, actually implemented some processing of the bytes like reprinting them.

I simply removed most of the code in this file to write my own driver.
(https://bbs.espressif.com/viewtopic.php ... 191#p22191)


I had to do the same.
I wrote about it here on how I got 3 TX pins from the ESP using a SoftUart to write to one of them.
Look for "softuart_write".
http://controllingtheinter.net/2018/06/ ... nonos-sdk/

Who is online

Users browsing this forum: No registered users and 6 guests