Compile at-example with NONOS SDK 2.2.0 in Eclipse not possible

sirc_xy
Posts: 1
Joined: Fri Apr 13, 2018 3:29 am

Compile at-example with NONOS SDK 2.2.0 in Eclipse not possible

Postby sirc_xy » Fri Apr 13, 2018 3:51 am

Hi there,

I am introducing myself to the world of ESP8266 and I am starting with simple AT commands. The thing is the following: I installed Eclipse, MinGW and the "Unofficial Espressif ESP8266 dev kit". I opened Eclipse, started a new project and added the source codes from C:/Espressif/examples/at, I also followed several configuration steps and I was able to compile the code and flash it into my ESP-02 board. That example flashes the 0.4.0 version of the at commands.

But now I updated the SDK version to 2.2.0, and I noticed that inside that folder there is another folder called "examples" with a newer "at source codes" version(C:/Espressif/ESP8266_SDK/examples/at), that would be version 1.6.0.

When I want to compile this new version of "at" software with eclipse, there are many problems with the makefile.

Does anyone have an idea on how to correctly do this? or a tutorial? it would be much apreciated.

Who is online

Users browsing this forum: No registered users and 9 guests